Package Details: bareos-bat 16.2.4-1

Git Clone URL: https://aur.archlinux.org/bareos-x11.git (read-only)
Package Base: bareos-x11
Description: Bareos - Backup Archiving REcovery Open Sourced - Admin Tool (GUI)
Upstream URL: http://www.bareos.org
Licenses: AGPL3
Groups: bareos
Submitter: spradlim
Maintainer: spradlim
Last Packager: spradlim
Votes: 3
Popularity: 0.016605
First Submitted: 2015-04-04 05:10
Last Updated: 2016-10-30 22:19

Latest Comments

spradlim commented on 2015-12-01 17:59

Yes, I thought about making this change and I still may. I would rather have the upstream maintainer fix this. I created a bug for him @ https://bugs.bareos.org/view.php?id=576

jenglisch commented on 2015-12-01 16:35

i've solved it with renaming bat to bareos-bat - http://paste2.org/Av48e16p
conflicting with alsa makes bat pretty useless, since it is designed as a desktop application, and i'm not going to uninstall alsa ;)

spradlim commented on 2015-12-01 02:39

Thanks, added conflict. Which is unfortunate...

Yes this was new with 1.1, I had a previous version installed.

jenglisch commented on 2015-12-01 02:31

https://www.archlinux.org/packages/extra/x86_64/alsa-utils/

=> View the file list for alsa-lib
=>
usr/bin/bat
usr/share/man/man1/bat.1.gz

i guess those got introduced with 1.1

spradlim commented on 2015-11-22 18:53

This doesn't make any sense

I looked at the package alsa-utils and it does not have the executable bat or man page for it.

I also have bat installed with alsa-utils and haven't seen a problem.

jenglisch commented on 2015-11-22 18:48

bacula-bat conflicts with alsa :/

error: failed to commit transaction (conflicting files)
alsa-utils: /usr/bin/bat exists in filesystem
alsa-utils: /usr/share/man/man1/bat.1.gz exists in filesystem

spradlim commented on 2015-11-16 05:01

The following message is expected when running makepkg. Please disregard this message install will work as expected. I will fix this soon.

PKGBUILD.common: line 98: /home/m/bareos/src/bareos-Release-15.2.1/debian/bareos-common.install: No such file or directory

spradlim commented on 2015-04-18 14:29

Thanks, should be fixed.
I noticed I don't preserve config files when upgrading. I just wanted to warn you. I will fix this later.

PiroXiline commented on 2015-04-18 11:36

When installing error "warning: cannot resolve "x11", a dependency of "bareos-traymonitor"" appears.

There is no package named x11 exist in ARCH packages/AUR.

This wrong dependency marked in "depends=("bareos-common=$pkgver" "x11")" in "PKGBUILD.common". As I understand "PKGBUILD.common" inserted in main "PKGBUILD".

Also this package is marked as "pkgbase='bareos-x11'" split package on pair with "bareos-bat", so this dependency error affecting installation of "bareos-bat" package too.

So we can solve it changing this dependency line.

PiroXiline commented on 2015-04-18 11:31

When installing error "warning: cannot resolve "x11", a dependency of "bareos-traymonitor"" appears.

There is no package named x11 exist in ARCH packages/AUR.

This wrong dependency marked in "depends=("bareos-common=$pkgver" "x11")" in "PKGBUILD.common". As I understand "PKGBUILD.common" inserted in main "PKGBUILD".

Also this package is marked as "pkgbase='bareos-x11'" split package on pair with "bareos-bat", so this dependency error affecting installation of "bareos-bat" package too.

So we can solve it changing this dependency line.

All comments