Package Details: barrier-git 2.3-2

Git Clone URL: https://aur.archlinux.org/barrier-git.git (read-only, click to copy)
Package Base: barrier-git
Description: Open-source KVM software based on Synergy (GUI)
Upstream URL: https://github.com/debauchee/barrier
Licenses: custom:GPL2WithOpenSSLException
Conflicts: barrier
Provides: barrier
Submitter: tallero
Maintainer: tallero
Last Packager: tallero
Votes: 3
Popularity: 0.164417
First Submitted: 2019-04-16 18:50
Last Updated: 2019-08-28 08:03

Latest Comments

Berengal commented on 2019-11-03 08:16

Can you add 'armv7h' to the 'arch' field please? I built and tested this on a raspberry pi 4 running archlinuxarm and it works just fine.

dude commented on 2019-09-21 13:13

Can you add 'git' to your makedepends please?

See https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines

mirh commented on 2019-09-14 15:33

Why is the barrier-headless-git dependency put in the package step rather than the main header? It's not like you are even making split packages.

In fact.. Why are there even two separate pkgbuilds for the two barrier and barrier-headless? It seems wasteful having to download and build the things twice.

evernow commented on 2019-09-03 22:11

Unfortunately I still get this:

Preparing... Cloning barrier-git build files... Checking barrier-git dependencies... Cloning barrier-headless-git build files... Checking barrier-headless-git dependencies... Error: unresolvable package conflicts detected Failed to prepare transaction. Failed to prepare transaction: conflicting dependencies: barrier-git and barrier-headless-git are in conflict

tallero commented on 2019-08-28 08:09

@evernow the dependency was already listed in the PKGBUILD and now barrier-headless-git has been correctly added to the .SRCINFO, too.

Does this imply the tools you used read dependency from the latter instead of the first?

Can you re-check now it is working?

evernow commented on 2019-08-27 21:26

Unfortunately I cannot build this, from either yay or pamac.

==> Leaving fakeroot environment. ==> Finished making: barrier-git 2.3-2 (Tue 27 Aug 2019 05:17:51 PM AST) ==> Cleaning up...

Resolving dependencies... Failed to prepare transaction: could not satisfy dependencies: unable to satisfy dependency 'barrier-headless-git=2.3-2' required by barrier-git

tallero commented on 2019-08-06 12:39

@luciferin: fixed

luciferin commented on 2019-08-05 18:31

Currently getting an error because you are sourcing the barrier-headless dependecy version with the line ""barrier-headless-git=${pkgver?}-${pkgrel?}". The version of barrier-git is 2.3-3, but barrier-headless-git is 2.3-1

I was able to edit the line manually to get the package to install.

tallero commented on 2019-08-03 22:38

@siretty split the packages in two https://aur.archlinux.org/packages/barrier-headless-git/

siretty commented on 2019-07-31 10:02

When using certain AUR helpers (eg. pacaur), the PKGBUILD fails to install.

At least pacaur looks for a barrier-headless-git package in the AUR since it is listed as a dependency of barrier-git, but fails als barrier-headless-git is not registered as a package in the AUR.

Just to be clear: The PKGBUILD is good and builds both packages perfectly fine when using makepkg manually, you just need to add the package barrier-headless-git with the same package base to the AUR to enable AUR helpers to work.