Package Details: barry 0.18.5-4

Git Clone URL: (read-only)
Package Base: barry
Description: Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices.
Upstream URL:
Licenses: GPL
Submitter: hwesselmann
Maintainer: Chazza
Last Packager: Chazza
Votes: 45
Popularity: 0.003183
First Submitted: 2008-10-20 13:11
Last Updated: 2017-06-17 10:22

Latest Comments

Chazza commented on 2017-06-17 10:13

Thanks for the heads up cmc :) Fixed now.

cmc commented on 2017-06-17 09:55

Builds like a charm but needs additional dependency libxml++2.6

Chazza commented on 2016-09-17 09:29

Sorry, but what do you mean by "the patches are missing"?

throbscottle commented on 2016-09-16 20:44

The patches are missing. I removed them from the PKGBUILD, but then I get a build failure. I tried changing the package to the .tar.bz2 version, but it also fails.

Chazza commented on 2015-10-27 21:48

Well I get this: local/arch:@/tmp/.ICE-unix/1476,unix/arch:/tmp/.ICE-unix/1476
Apparently it's something that should be set by the DE or WM.

But actually, I don't think it's the problem in this case because I tried running barrydesktop in TWM which doesn't set SESSION_MANAGER and I didn't get a segfault.

I'm afraid I'm not really sure what more I can do to help at this point - I can't reproduce the segfault under any conditions. You probably want to get strace and gdb output to find out what's really going on when barry crashes and then see if anyone in the forums can help you or possibly upstream.

If there's anything that comes up that I can implement then please let me know and thanks for reporting that build failure.

captainju commented on 2015-10-27 15:52

echo $SESSION_MANAGER returns nothing (empty)
I'm using awesome WM and I don't know what should be in SESSION_MANAGER

Chazza commented on 2015-10-27 12:30

The lines regarding wxgtk and opensync are not significant. I think it's the session manager line that's important. What does echo $SESSION_MANAGER return?

captainju commented on 2015-10-27 09:02

It builds :) Thank you

But I get seg fault :

I don't know why

Chazza commented on 2015-10-25 14:20

As it turns out, version 0.18.5 exists (though the NetDirect website still states that 0.18.4 is the highest) so I've updated this package to the newer version.

Chazza commented on 2015-10-24 16:22

@captainju Can you try building now? I've just pushed a fix. As far as I understand, the problem was that libxml++ and friends now want C++11 as per [1]. This means we have to force C++11 by building with the -std=c++11 flag. That causes errors elsewhere so I've created a patch to take care of those. Building with C++11 still raises a large number of warnings but I figure it's NetDirect's job to sort that out!


Chazza commented on 2015-10-23 12:38

Confirmed. I'll see what I can do about this in a bit.

captainju commented on 2015-10-23 08:01

I'm not able to build it

Chazza commented on 2015-05-03 10:47

Seeing as sync is still not working properly, there's no sense in compiling support for it so I've removed libopensync-stable as a dependency.

Chazza commented on 2015-03-29 14:35

Trivial update to replace manual removal of libtool files with the !libtool option. No need to update. I still haven't figured how to get opensync working properly yet. If anyone has any suggestions regarding fixing opensync, they would be most welcome.

Chazza commented on 2015-03-23 14:37

@Lazy, Oh yeah, I forgot to mention, I've filed an orphan request against libgcal. I've also pasted a link to an updated libgcal PKGBUILD in the comments there.

Regarding libopensync - that doesn't seems to be working yet annoyingly. The libopensync-stable package builds fine and barry builds the opensync plugin against that library just fine. The trouble is, barry isn't recognising any opensync plugins. I'll keep working on this and let you all know when I have a solution.

Lazy commented on 2015-03-23 13:55

Might use libgcal-git as libgcal doesn't have package() yet.

Chazza commented on 2015-03-23 09:49

This updated PKGBUILD enables the full desktop interface, as seen in the screenshots here:

I've also enabled the opensync plugin so that we barry has syncing functionality.

A note on opensync, there are actually 2 opensync plugins, the opensync plugin which is legacy, hails from 2007 and needs to be built against the libopensync 0.2x series. There is also the opensync-4x plugin which is more current and is built against libopensync 0.39 which is in the official repos. Sadly, I could not for the life of me get barry to build the opensync-4x plugin. First I had pkg-config errors and then once I resolved those I had compile failures. So we're stuck with legacy opensync but I figure it's better than no sync at all.

If somebody can get the opensync-4x plugin working I'd be interested to know.

Chazza commented on 2015-03-22 22:08

Will update this tomorrow.

n4zm830 commented on 2015-01-12 08:01

At the moment I can't install the built package, error:
barry: /usr/sbin exists in filesystem
So I add two lines to package() function:

cp -a $pkgdir/usr/sbin/. $pkgdir/usr/bin
rm -r $pkgdir/usr/sbin

V155 commented on 2014-01-15 05:44

I can confirm that it builds fine but without the patch.
So took the orphaned package and submitted a modified PKGBUILD.

llmage commented on 2013-12-18 19:56

same as r.b: build failed with " error: invalid conversion from 'ssize_t (*)(long int, const void*, size_t)" when using patch, works kindof fine without

r.b commented on 2013-11-14 20:29

It looks like the patch is not needed in 0.18.4. I was able to compile without it but not with it.

V155 commented on 2013-11-07 08:59

At the moment Im not able to build it.
tried 0.18.4 abd 0.18.3 both give the same error

TrialnError commented on 2013-09-15 19:14

Took the PKGBuild presented by V155 and updated it to the latest guidelines

kinu commented on 2013-06-03 19:30

Same thing here. Any solution?

V155 commented on 2013-05-04 21:06

Here is an updated PKGBUILD (use tarfile-ops-nt-cc.patch as per original)
Should work fine. Only pppob was tested
link to PKGBUILD:

pkgdesc="A GPL C++ library for interfacing with the RIM BlackBerry Handheld"
arch=('i686' 'x86_64')
depends=('libusbx' 'zlib' 'libglademm' 'libtar' 'libxml++')
makedepends=('make' 'gcc' 'patch' 'pkg-config' 'autoconf' 'automake' 'libtool' 'gettext')

optdepends=('fuse: for mounting the BB database with bfuse'
'sdl: for grabbing screenshots with bwatch'
'ppp: for tethering with pppob')


build() {
# Apply patches
cd $srcdir/$pkgname-$pkgver/src
patch -p0 < ../../

# Build the package
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr --enable-gui
make || return 1
make DESTDIR=$pkgdir install

# Install PPP scripts for pppob
mkdir -p $pkgdir/etc/ppp/peers/ $pkgdir/etc/chatscripts/
find $srcdir/$pkgname-$pkgver/ppp/ -name *.chat -exec cp {} $pkgdir/etc/chatscripts/ \;
find $srcdir/$pkgname-$pkgver/ppp/ ! -name *.chat ! -name README -exec cp {} $pkgdir/etc/ppp/peers/ \;

# Remove libtool files
find "$pkgdir/" -name "*.la" -exec rm {} \;

V155 commented on 2013-05-04 21:03

PKGBUILD to build the actual version.
Only pppob was tested and worked fine.

Anonymous comment on 2013-02-18 03:18

failed to build..

src/ installing './depcomp' error: 'AM_PROG_CC_STDC': this macro is obsolete.
You should simply use the 'AC_PROG_CC' macro instead.
Also, your code should no longer depend upon 'am_cv_prog_cc_stdc',
but upon 'ac_cv_prog_cc_stdc'.
/usr/share/aclocal-1.13/obsolete-err.m4:17: AM_PROG_CC_STDC is expanded from... the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1 error: 'AM_PROG_CC_STDC': this macro is obsolete.
You should simply use the 'AC_PROG_CC' macro instead.
Also, your code should no longer depend upon 'am_cv_prog_cc_stdc',
but upon 'ac_cv_prog_cc_stdc'.
/usr/share/aclocal-1.13/obsolete-err.m4:17: AM_PROG_CC_STDC is expanded from... the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
==> ERROR: A failure occurred in build().

Anonymous comment on 2012-11-20 11:41

Even if I remove "--enable-opensync-plugin-4x", it doesn't build:

configure: error: Unable to find a GUI oriented su wrapper.

This is required for modem operation, in case permissions are not
set on pppd properly.

Please specify the GUI su wrapper you wish to use with the
--with-guisu configure option. Note that it MUST be a GUI.
You cannot use the command line su.

Anonymous comment on 2012-11-20 11:34

configure: error: Package requirements (libopensync1) were not met:
No package 'libopensync1' found

The package libopensync-0.39 is installed.

Anonymous comment on 2012-07-15 08:50

Here is an updated PKGBUILD (use tarfile-ops-nt-cc.patch as per original)

pkgdesc="Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld."
arch=('i686' 'x86_64')
depends=('libusb-compat' 'zlib' 'libglademm' 'libtar' 'libxml++')
makedepends=('make' 'gcc' 'patch' 'pkg-config' 'autoconf' 'automake' 'libtool' 'gettext')

optdepends=('fuse: for bfuse')


build() {
# Apply patches
cd $srcdir/$pkgname-$pkgver/src
patch -p0 < ../../

# Build the package
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr --enable-gui
make || return 1
make DESTDIR=$pkgdir install

# Remove libtool files
find "$pkgdir/" -name "*.la" -exec rm {} \;

Anonymous comment on 2012-05-26 13:21

Yesterday the team released the version 1.8.3.

Anonymous comment on 2012-05-10 09:05

Last week the team behind Barry realesed the version 0.18.0.

Anonymous comment on 2010-12-29 23:57

With current git revision, it doesn't patch anymore.

r.b commented on 2010-05-13 05:51

Thanks for pointing that out, monshin. The makedepends have been updated.

Anonymous comment on 2010-05-12 00:09

Please add to makedepends autoconf and automake. Thanks.