Package Details: bas 2.4-1

Git Clone URL: https://aur.archlinux.org/bas.git (read-only)
Package Base: bas
Description: A BASIC interpreter
Upstream URL: http://www.moria.de/~michael/bas/
Keywords: basic interpreter programming
Licenses: GPL
Submitter: None
Maintainer: ids1024
Last Packager: ids1024
Votes: 1
Popularity: 0.000000
First Submitted: 2010-08-27 03:47
Last Updated: 2015-06-13 03:14

Latest Comments

ids1024 commented on 2015-02-13 00:27

Updated.

Fredo commented on 2015-02-12 20:13

new version is out.

Change the following:

pkgver=2.4
md5sums=('f2a0c85e5341ae425959413c7e850517')

aaronp commented on 2012-10-10 06:25

# Maintainer: Zhang Li <msfxzi at sina.com>
pkgname=bas
pkgver=2.3
pkgrel=1
pkgdesc="A BASIC interpreter"
arch=(i686 x86_64)
url="http://www.moria.de/~michael/bas/"
license=('GPL')
depends=('glibc')
makedepends=('gcc')

source=("http://www.moria.de/~michael/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('4a6c1006f309049b2eb74bfa59cae0b90a78c01d9d3d436872d9afbd96f9155d')

build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr || return 1
make || return 1
make prefix=${pkgdir}/usr install
}

Anonymous comment on 2012-06-08 19:07

Also, this compiles and runs on ARM, so the arch=() parameter can have arm added if you wish.

Anonymous comment on 2012-06-08 18:59

This fails due to package not being found. The following need to be changed in the PKGBUILD for it run:

pkgver=2.2
source=("http://www.moria.de/~michael/bas/bas-2.2.tar.gz")
md5sums=("0426998d2d5e3bf4afbcda86d746f1cf")