Package Details: base-devel-meta 2021.08.07-1

Git Clone URL: https://aur.archlinux.org/base-devel-meta.git (read-only, click to copy)
Package Base: base-devel-meta
Description: Metapackage for all the base-devel group.
Upstream URL: https://www.archlinux.org/
Keywords: arch development makepkg meta
Licenses: None
Conflicts: meta-group-base-devel
Provides: meta-group-base-devel
Replaces: meta-group-base-devel
Submitter: whynothugo
Maintainer: whynothugo
Last Packager: whynothugo
Votes: 27
Popularity: 1.88
First Submitted: 2021-08-07 11:15 (UTC)
Last Updated: 2021-08-07 11:20 (UTC)

Latest Comments

aminvakil commented on 2021-08-07 12:57 (UTC)

I've created one for you ;)

https://lists.archlinux.org/pipermail/aur-requests/2021-August/057093.html

whynothugo commented on 2021-08-07 11:16 (UTC)

I've created base-devel-meta as a successor to this package.

Given replaces, conflicts and provides, transition should go smoothly.

I'll put up a request for a TU to merge this package into that one if a few days, but I'm giving a heads up here first.

Ta180m commented on 2021-06-19 23:31 (UTC)

@whynothugo Why not rename the package? You can use replaces in the PKGBUILD to ensure the transition goes smoothly.

whynothugo commented on 2021-06-17 06:56 (UTC)

This package predates ones like "base", hence the naming. Back in the day, there was no meta package for "base", just a group.

Ta180m commented on 2021-06-16 23:28 (UTC)

Why isn't this package named base-devel-meta? Isn't that more consistent with how the meta packages in the official repositories are named?

tleydxdy commented on 2021-04-24 15:04 (UTC)

Yes, I mean removed from the dependency list. but I see your point.

whynothugo commented on 2021-04-24 14:19 (UTC)

@tleydxdy AUR packages have maintainers, so they can be updated if you find any issue on them. No need to be overzealous and DELETE anything that doesn't meet your standards.

That said, this package depends on packages in base-devel. The fact that grep and sed are both part of base and base-devel are beyond my control.

tleydxdy commented on 2021-04-24 03:18 (UTC)

I think packages that base depends on like grep sed and friends should be removed. since now base is a package and it needs to be installed at all times

whynothugo commented on 2020-01-28 14:18 (UTC)

Updated. Thanks!

polospartan commented on 2020-01-27 08:58 (UTC)

Hi, There are 24 packages in the base-devel group: systemd and util-linux dependencies should be removed. Cheers

PhotonX commented on 2016-07-06 14:37 (UTC)

Please remove the brackets from the url field (makepkg reports that url should be not an array).