Package Details: basex 8.5.3-1

Git Clone URL: (read-only)
Package Base: basex
Description: Light-weight, high-performance XML database system and XPath/XQuery processor.
Upstream URL:
Licenses: BSD
Submitter: chheien
Maintainer: drrossum
Last Packager: drrossum
Votes: 21
Popularity: 0.047449
First Submitted: 2010-07-04 06:43
Last Updated: 2016-08-30 14:58

Latest Comments

Admat81 commented on 2016-05-12 16:16

@maxf: hmmm... I have installed all 'java-runtime" stuff (jre8-openjdk-headless, jre8-openjdk, jdk8-openjdk) but I had no set default Java environment. So I used this: 'archlinux-java fix' and after that I installed BaseX from AUR package sucessfull without any problems :D Thanks!

maxf commented on 2016-05-12 11:25

@Admat81: You're missing 'java-runtime', which is missing as a dependency in this package. Install a JRE (for example jdk8-openjdk since you'll probably also want javac) to fix this.

Admat81 commented on 2016-05-12 11:14

When I try install it, I have ERROR:

/tmp/yaourt-tmp-user/aur-basex/./PKGBUILD: line 39: jar: command not found
A failure occurred in package().
Makepkg was unable to build basex.

I'm new and I don't know, how to install it correctly :(

maxf commented on 2016-04-25 08:26

Since 'jar' is called as part of the build step, this package should depend on 'java-runtime' instead of 'java-environment-common'. Otherwise the build will fail in a clean chroot...

goodmami commented on 2015-11-20 20:40

Minor issue. The icon path in BaseX.desktop is incorrect:


It should be:


kttr64 commented on 2015-07-09 17:08

Please update to 8.2.2
sha1sum is 1d17384dddd6f9788bfdce90904adfbf1b1327f6
Thank you

dmdobrowolski commented on 2015-03-18 11:53

Yes, now it is OK. Thank you.

drrossum commented on 2015-03-17 20:40

Thanks for pointing that out. Should be fixed now.

dmdobrowolski commented on 2015-03-17 17:28

makepkg doesn't work for version 8.0.1-1

The error message says:
install: cannot stat 'basex/license.txt': No such file or directory.
==> ERROR: A failure occured in package()

pocafe commented on 2015-03-02 18:47

Latest is 8.0.1

drrossum commented on 2014-12-11 18:56

Make sure your java environment is setup correctly. See also this news item

ram4nd commented on 2014-12-11 12:12

Still getting the same error.

ram4nd commented on 2014-12-11 12:11

/tmp/yaourt-tmp-root/aur-basex/./PKGBUILD: line 39: jar: command not found
==> ERROR: A failure occurred in package().
==> ERROR: Makepkg was unable to build basex.

drrossum commented on 2014-10-17 14:02

This is related to the recent renaming of java packages. I've updated the dependencies.

ram4nd commented on 2014-10-17 07:59

/tmp/yaourt-tmp-root/aur-basex/./PKGBUILD: line 39: jar: command not found
==> ERROR: A failure occurred in package().
==> ERROR: Makepkg was unable to build basex.

aevalo commented on 2014-08-09 18:35

7.9 is currently the latest.

fau commented on 2014-02-06 10:41

Latest is 7.7.2.

Anonymous comment on 2011-11-28 08:32

Version 7.0.2 is available, please update.

chheien commented on 2011-08-12 23:56

I recently found out the java-dependent PKGBUILDs I've made should originally have had "-bin" to the end since they use prebuilt .jar files.
Rather than rename all of them, I'm migrating them to be genuine "from-source" packages.
In that case you're right. I'll need to replace java-runtime with jdk and add all dependent build libraries. I'll rewrite the 6.7.1 to be compiled instead of binary.

Anonymous comment on 2011-08-12 14:21

Version 6.7.1 now available. Update please :)

Anonymous comment on 2011-08-12 14:16

To makepkg you actually require jdk. Should jdk not be added to dependancies in this case...?

koromilaz commented on 2011-07-02 16:49

Did another one for the current version.

chheien commented on 2010-12-08 01:34

Changed to pulling from maven repo instead of SourceForge.

chheien commented on 2010-12-08 00:37

I'm going to keep this version at what they call "Official Release" even though they recommend using the latest.
I'll work on a basex-latest to target the "latest" folder in their mvn repo. Thanks for the notice.

Anonymous comment on 2010-11-26 07:28

There is a 6.3.2 release in the Maven repository of the project.