Package Details: bashets 0.6.3-3

Git Clone URL: https://aur.archlinux.org/bashets.git (read-only)
Package Base: bashets
Description: User shellscript-powered library for Awesome WM, for widgets and something else
Upstream URL: http://gitorious.org/bashets
Licenses: GPL
Submitter: None
Maintainer: Midov
Last Packager: Midov
Votes: 27
Popularity: 0.020161
First Submitted: 2009-10-03 13:32
Last Updated: 2015-11-07 14:19

Required by (0)

Sources (0)

Latest Comments

Midov commented on 2015-04-02 06:34

Hey guys, i noticed links in PKGBUILD were not working so i found sources on google code and copied them to github.
I also fixed PKGBUILD a little so its more like in Arch packaging standards. Also, it builds now.

Let me know if everything is okay since its first package im maintaining on AUR and i currently have no clue what im doing.

libgradev commented on 2013-02-04 12:09

Tested under Awesome 3.5 here: Loads fine, test widget works.

libgradev commented on 2013-01-07 15:24

Believe this is compatible with stable again now (http://awesome.naquadah.org/wiki/Bashets "Note: Bashets is compatible with awesome 3.5 and greater.")

Anonymous comment on 2012-06-24 17:00

fixed access rights for scripts in /usr/share/awesome/bashets/, now they are executable by default :)

Anonymous comment on 2012-06-23 07:41

Added Lua 5.2 compatibility, but tested only on Lua 5.1. If you experience any problems, please tell here or via email.

Anonymous comment on 2012-01-08 10:03

Also in this version I've fixed Pango markup issue: entities were not encoded properly every time.

Anonymous comment on 2012-01-08 10:02

Again added awesome-git instead of awesome to dependencies.

If anyone cares to help with stable version, please fix util.get_widget_meta() function to work with old-fashion widgets and email me a patch.

Anonymous comment on 2011-07-03 18:13

I've added backwards compatibility fixes.
It should now work with stable awesome.

If not - please report here, I shall fix it.

Anonymous comment on 2011-05-02 16:18

0.6 is here with initial support for dbus

to try dbus stuff, simply add the following line to your rc.lua for any widget you like:
bashets.register("org.freedesktop.UDisks", {dbus = true, busname = "system", format = "$3", widget = yourwidget})

if you add or remove device, you'll see corresponding udisks event name on your widget

Anonymous comment on 2011-04-30 17:43

p.s.: yes, the first issue will be fixed in bashets 0.6, but I also plan to add one new feature to that release, so it should come a bit later

All comments