Package Details: batman-adv 2016.0-2

Git Clone URL: https://aur.archlinux.org/batman-adv.git (read-only)
Package Base: batman-adv
Description: batman kernel module
Upstream URL: http://www.open-mesh.net/
Licenses: GPL
Submitter: ilpianista
Maintainer: t-8ch
Last Packager: t-8ch
Votes: 6
Popularity: 0.000025
First Submitted: 2011-06-07 09:26
Last Updated: 2016-02-19 18:08

Latest Comments

RubenKelevra commented on 2016-01-21 09:24

Thanks for the fast update! :)

RubenKelevra commented on 2016-01-18 13:21

https://www.open-mesh.org/projects/open-mesh/wiki/2015-11-26-batman-adv-2015-2-release

RubenKelevra commented on 2015-09-29 20:40

Thanks!

RubenKelevra commented on 2015-09-21 14:59

Hi t-8ch,

I understand you, but it wasn't my intention to let you include custom-patches. All patches mentioned has already be merged upstream and are backported. The are all backported for stability or bugfix reasons, and should be only necessary until 2015.2 is released.

If you still want to keep the patchset as small as possible, I'd like to select some very critical ones.

Thanks for your fast response!

t-8ch commented on 2015-09-21 14:24

Hi Ruben,

those look mostly like features and new default settings to me.
To be honest I'd like to keep this package as vanilla as possible (If some patches are critical bugfixes for vanilla batmand-adv, please let me know!)
I propose to create a new package batmand-adv-{openwrt,freifunk,preview,...}
If you want you can create/maintain this package or I make a split package out of this package.
I am also happy to create a postinst message pointing users to the new package.

RubenKelevra commented on 2015-09-21 13:48

There are some patches which are still very important, but doesn't met the 2015.1 release... can you please add them as well?

https://github.com/openwrt-routing/packages/tree/master/batman-adv/patches

https://github.com/freifunk-gluon/gluon/blob/master/patches/packages/routing/0003-batman-adv-decrease-maximum-fragment-size.patch

Thanks!

RubenKelevra commented on 2015-09-01 10:31

2015.1 is a very important bugfix-release, would be great if you can manage a update soon! :)

Best regards

Ruben

RubenKelevra commented on 2015-05-09 11:25

2014.4 does not compile anymore because some warnings are treated as errors

/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gen-compat-autoconf.sh /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/compat-autoconf.h
make -C /usr/lib/modules/4.0.1-1-ARCH/build M=/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0 PWD=/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0 modules
make[1]: Verzeichnis „/usr/lib/modules/4.0.1-1-ARCH/build“ wird betreten
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/compat.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/bitarray.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/bat_iv_ogm.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/bridge_loop_avoidance.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/debugfs.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/distributed-arp-table.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/fragmentation.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_client.o
CC [M] /tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_common.o
/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_common.c: In Funktion »batadv_parse_gw_bandwidth«:
/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_common.c:47:3: Fehler: Implizite Deklaration der Funktion »strnicmp« [-Werror=implicit-function-declaration]
if (strnicmp(tmp_ptr, "mbit", 4) == 0)
^
cc1: Einige Warnungen werden als Fehler behandelt
scripts/Makefile.build:258: die Regel für Ziel „/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_common.o“ scheiterte
make[2]: *** [/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0/gateway_common.o] Fehler 1
make[2]: *** Es wird auf noch nicht beendete Prozesse gewartet...
Makefile:1390: die Regel für Ziel „_module_/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0“ scheiterte
make[1]: *** [_module_/tmp/yaourt-tmp-ruben/aur-batman-adv/src/batman-adv-2014.4.0] Fehler 2
make[1]: Verzeichnis „/usr/lib/modules/4.0.1-1-ARCH/build“ wird verlassen
Makefile:53: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2

RubenKelevra commented on 2015-05-09 11:22

Batman-adv 2015.0 is out.

http://downloads.open-mesh.org/batman/releases/batman-adv-2015.0/

zootboy commented on 2014-11-26 20:16

Couple of patches to make it work with 3.17 (at least until the next official release)

http://pastebin.com/0XyxW2QC
http://pastebin.com/G2kB62qL

All comments