Package Details: bats-core 1.2.1-1

Git Clone URL: https://aur.archlinux.org/bats-core.git (read-only, click to copy)
Package Base: bats-core
Description: Bash Automated Testing System
Upstream URL: https://github.com/bats-core/bats-core
Licenses: MIT
Conflicts: bash-bats
Provides: bash-bats
Submitter: schra
Maintainer: schra
Last Packager: schra
Votes: 3
Popularity: 0.64
First Submitted: 2019-10-23 19:16
Last Updated: 2020-08-03 01:10

Required by (5)

Sources (1)

Latest Comments

pamrg commented on 2020-06-02 01:00

@schra thanks for your patience. I learn :) And thx for maintaining the package. I love using bats

schra commented on 2020-06-01 12:50

@pamrg Thanks for your reply. You are correct, base-devel is assumed by AUR packages. See https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

pamrg commented on 2020-06-01 02:25

It's working now. I installed some other packages in the meantime and can't reproduce it. I believe it's base-devel group that wasn't installed. I don't seem to be able to remove it for testing as it shows me a long list of breaking dependencies. Maybe having one of the base-devel programs as a dependency is not the responsibility of the package as it should be installed anyway?

schra commented on 2020-05-31 11:48

@pamrg I can't reproduce your error. Please open an issue in the upstream repo as this is probably not a packaging error, and post the link to the upstream issue in the comments here, so I can follow the issue.

pamrg commented on 2020-05-31 02:53

Hi friends, I m getting an error when installing bats-core: for test 78:

# (in test file test/suite.bats, line 143)
#     `[[ "${lines[$i]" == "ok" $i slow test $t" ]]` failed
==> ERROR: A failure occured in check().

and for test 56: same error but on test/bats.bats, line 481 Anybody has the same problem?

schra commented on 2020-05-13 17:54

@prestidigitation Maybe there is a shortcut to get it into community, but I guess the first step would be to vote for this package :)

I also think that the bash-bats package itself will never be updated to bats-core. I sent the maintainer of the bash-bats package an email and asked if they could update the package to using bats-core instead of bats. They never responded and thus I created this package.

prestidigitation commented on 2020-05-13 15:57

Is there a way to get this into the Community repo, since https://www.archlinux.org/packages/community/any/bash-bats/ is outdated? Development moved from https://github.com/sstephenson/bats to https://github.com/bats-core/bats-core several years ago.

damien.flament commented on 2019-10-25 20:29

I use aura. It is a wrapper around pacman which manage package through official repositories and AUR.

But I'm not surprised it didn't works because the path file was not specified in the sources.

The fix works well.

schra commented on 2019-10-24 20:38

@damien.flament Sorry about that. How did you try to install the package? I could install the package via aurman without any problems. I published a fix but as I can't replicate your error I also can't test it. Can you confirm that my fix works for you?

damien.flament commented on 2019-10-24 11:57

The file ../../fix-libexec-path.patch is not found when building the package. It does not appears in the list of sources.