Package Details: bbswitch-ck 0.8-17

Git Clone URL: https://aur.archlinux.org/bbswitch-ck.git (read-only)
Package Base: bbswitch-ck
Description: Kernel module allowing to switch dedicated graphics card on Optimus laptops for linux-ck
Upstream URL: http://github.com/Bumblebee-Project/bbswitch
Keywords: bbswitch ck nvidia
Licenses: GPL
Provides: bbswitch
Submitter: jdbrown
Maintainer: Distorted
Last Packager: Distorted
Votes: 22
Popularity: 0.275976
First Submitted: 2014-02-19 14:16
Last Updated: 2016-06-25 17:19

Required by (3)

Sources (1)

Latest Comments

Distorted commented on 2016-03-27 11:31

@petterk
You need to remove bbswitch-ck first, and then reinstall it after upgrading your kernel.

petterk commented on 2016-03-27 11:20

error: failed to prepare transaction (could not satisfy dependencies)
:: bbswitch-ck: installing linux-ck-haswell (4.4.6-1) breaks dependency 'linux-ck<4.4'

Distorted commented on 2016-02-02 10:09

@Andr0med4
Thanks for pointing that out.

Andr0med4 commented on 2016-02-02 05:41

Seems like pacman 5.0 changed the way urls in the PKGBUILD are handled. Building this package stopped with "ERROR: url should not be an array".

Replacing url=("http://github.com/Bumblebee-Project/bbswitch") by url="http://github.com/Bumblebee-Project/bbswitch" solved this error for me.

Distorted commented on 2015-11-23 12:28

@petterk you need to remove bbswitch-ck first before installing the new kernel, and then rebuild it for the new version.

petterk commented on 2015-11-23 12:18

error: failed to prepare transaction (could not satisfy dependencies)
:: bbswitch-ck: requires linux-ck<4.2

repo-ck/linux-ck-haswell 4.1.13-1 (ck-haswell)

kyak commented on 2015-11-13 17:53

This package doesn't work now with linux-ck-ivybridge (see recent discussion on https://aur.archlinux.org/pkgbase/linux-ck). What can be done here? It used to work before.

My bad. I was using the older version of linux-ck-ivybridge from repo-ck (completely forgot about it). Sorry!

FadeMind commented on 2015-08-10 12:06

petterk
purge bbswitch-ck first.
ugrade kernel.
instal new one bbswitch-ck.

See previous comments.

petterk commented on 2015-08-10 11:58

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: bbswitch-ck: requires linux-ck<4.1

Compizfox commented on 2015-08-05 23:07

@FadeMind: Thanks for your reply. I didn't know about this AUR4 thing until I wanted to register and it redirected me to aur4.archlinux.org.

Is this the recommended way of migrating to AUR4? Seems hacky...

All comments