Package Details: bbswitch-dkms 0.8-1

Git Clone URL: https://aur.archlinux.org/bbswitch-dkms.git (read-only)
Package Base: bbswitch-dkms
Description: kernel module allowing to switch dedicated graphics card on Optimus laptops, dkms version
Upstream URL: https://github.com/Bumblebee-Project/bbswitch
Licenses: GPL
Conflicts: bbswitch, bbswitch-git
Provides: bbswitch
Replaces: dkms-bbswitch
Submitter: Lekensteyn
Maintainer: Lekensteyn
Last Packager: Lekensteyn
Votes: 93
Popularity: 3.993127
First Submitted: 2013-04-05 22:23
Last Updated: 2016-02-09 16:45

Dependencies (1)

Required by (3)

Sources (2)

Latest Comments

Lekensteyn commented on 2016-02-09 16:45

@Claudiop fixed, thanks for reporting!

Claudiop commented on 2016-02-08 00:56

ERROR: url should not be an array
Please remove the parenthesis from the url line.

Lekensteyn commented on 2013-12-05 10:17

Kernel 3.13 compatibility has been added with version 0.8-1.

Lekensteyn commented on 2013-05-28 19:42

Version 0.7 is released, fixing a scary WARNING since Linux 3.9.

alucryd commented on 2013-04-05 22:29

Thx, I merged the packages. Going to sleep too :)

Lekensteyn commented on 2013-04-05 22:24

Thanks for your review, I have uploaded a new package at https://aur.archlinux.org/packages/bbswitch-dkms/, resetting pkgrel and correcting the replaces line. I have tested it and pacman handles it correctly. Need sleep too, good night.

alucryd commented on 2013-04-05 21:45

Youpi: You're right, I missed that one, should probably go to bed ;) (be careful, it's replaces, not replace)

alucryd commented on 2013-04-05 21:44

Youpi: You're right, I missed that one, should probably go to bed ;)

alucryd commented on 2013-04-05 21:43

Lekensteyn: You don't need to bump the pkgrel, other than that it's fine. You can drop the replaces line when you feel everybody has switched to your new package. A provides line would be useful only if a package depended on this one, and could be dropped as soon as said package would have updated its deps.

Youpi commented on 2013-04-05 21:42

are you sure line 14: +replaces=('bbswitch-dkms')

is not : +replace=('dkms-bbswitch') instead ?

All comments