Package Details: bcalc 16.05.0-1

Git Clone URL: (read-only)
Package Base: bcalc
Description: Double-dummy solver for bridge (the card game).
Upstream URL:
Licenses: custom
Submitter: qwak
Maintainer: anntzer
Last Packager: anntzer
Votes: 4
Popularity: 0.000000
First Submitted: 2008-01-29 15:22
Last Updated: 2016-06-27 05:06

Latest Comments

anntzer commented on 2014-10-04 22:12

The link to download the old version of libcurl is out of date.

Afwas commented on 2012-07-12 04:54

Thanks again ;)

You should make that line
[ "$CARCH" = "x86_64" ] && md5sums[0]='49f9bf5592ef259af10bab62c4160f18'
to prevent the error: "Cannot assign a list to an array element" (translation by me)

Afwas commented on 2012-07-11 01:28

Thanks for the 03 Jul update. I have two issues:

1) Please change PKGBUILD to
[ "$CARCH" = "x86_64" ] && md5sums=('49f9bf5592ef259af10bab62c4160f18' '32ebb622ae7ef95626279a0dfc877964')
2) bcalcgui requires which I created through:
$ sudo cp /usr/lib/ /usr/lib/
The package boost-libs is at version 1.49.0-2. See

bcalc works fine now with only this warning:
bcalcgui2: /var/lib/bcalc/ no version information available (required by bcalcgui2)

Afwas commented on 2012-07-04 01:37

$ md5sum bcalc12070_linux_x86-64.tar.gz
49f9bf5592ef259af10bab62c4160f18 bcalc12070_linux_x86-64.tar.gz

Afwas commented on 2012-03-25 01:13

[me@arch bin]$ bcalcgui
bcalcgui: /usr/lib/ version `CURL_OPENSSL_3' not found (required by bcalcgui)

qwak commented on 2011-06-29 00:25

Dziękuję Krzysztofie, że zaopiekowałeś się moim pakietem. Ja wciąż nie mam Archa. Najnowsza wersja wprowadza trochę nowości i upgrade jest ciut bardziej kłopotliwy niż zwykle.
Po pierwsze bcalc zależy od lua w wersji 5.1 ('lua>=5.1' do depends).
Po drugie zawiera skrypty lua (katalog downloaders z plikami .lua) który warto warto umieścić w /var/lib/bcalc (tj. /var/lib/bcalc/downloaders powinien zawierać pliki .lua).

Piotr Beling

qwak commented on 2010-07-05 10:08

I have no Arch instillation at this moment (and I can't test new PKGBUILD), so now I orphan this package.

But this package is easy for upgrade (I am bcalc author), just fix pkg. version and md5 sums.
Md5 sums for newest version are always here: