Package Details: bearssl 0.6-4

Git Clone URL: https://aur.archlinux.org/bearssl.git (read-only, click to copy)
Package Base: bearssl
Description: Implementation of the SSL/TLS protocol (RFC 5246) written in C
Upstream URL: https://bearssl.org
Licenses: MIT
Submitter: concatime
Maintainer: concatime
Last Packager: concatime
Votes: 1
Popularity: 0.116502
First Submitted: 2019-08-03 00:02
Last Updated: 2021-06-15 19:41

Latest Comments

concatime commented on 2021-06-15 19:43

@guzzisti oops, sorry :) Fixed.

guzzisti commented on 2021-06-15 19:22

@concatime The new PKGBUILD is broken for me, this patch fixed it for me.

concatime commented on 2021-06-15 15:32

@Roshless done. @guzzisti done.

concatime commented on 2021-06-15 15:30

@m040601, arch=('any') is not valid:

$ namcap bearssl-0.6-3-any.pkg.tar.zst
bearssl E: ELF file ('usr/bin/brssl') found in 'any' package
bearssl E: ELF file ('usr/lib/libbearssl.so.0.6') found in 'any' package

And that makes sens since the binary generated is arch-restricted. So I listed all architectures from archlinux32.org and archlinuxarm.org.

concatime commented on 2021-06-14 17:13

Understood, will do everything by tomorrow.

m040601 commented on 2021-06-13 14:04

Please change:

arch=('x86_64')

to

arch=('any')

to follow the guidelines, https://wiki.archlinux.org/title/Arch_package_guidelines#Architectures

This is a C code program that compiles and runs perfectly in other architectures, as it only depends on glibc, https://bearssl.org .

We want to use it with ArchLinux ARM in Raspberry Pi's and chromebooks

Roshless commented on 2021-03-21 22:20

Hey, can you update .SRCINFO to match pkgrel from PKGBUILD?

guzzisti commented on 2021-03-04 17:41

Hi, would you please adjust the PKGBUILD to make the header file names match upstream: https://www.bearssl.org/apidoc/index.html

This patch works fine for me.