Package Details: beets-alternatives 0.10.2-1

Git Clone URL: https://aur.archlinux.org/beets-alternatives.git (read-only, click to copy)
Package Base: beets-alternatives
Description: Beets plugin to manage external files
Upstream URL: https://github.com/geigerzaehler/beets-alternatives
Licenses: MIT
Submitter: wisperwind
Maintainer: wisperwind
Last Packager: wisperwind
Votes: 0
Popularity: 0.000000
First Submitted: 2018-11-25 21:28
Last Updated: 2021-02-16 09:35

Latest Comments

wisperwind commented on 2020-10-11 18:15

Thanks @smilerish for investigating this and suggesting the change to beets-git! In fact, I had encountered this problem myself some time ago, but only resorted to installing beets-alternatives-git again, which lacks the ">=1.4.7" requirement (I should probably add that now)

smilerish commented on 2020-10-09 20:45

Struggling to get this installed with beets-git from AUR.

Verifying that beets is installed and version>=1.4.7:

$ pacman -Qi beets
Name            : beets-git
Version         : 1.4.9.r869.g52ca0cbf-1
[...]
Provides        : beets
[...]
Conflicts With  : beets

$ makepkg
==> Making package: beets-alternatives 0.10.1-1 (Fri Oct  9 20:30:21 2020)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> beets>=1.4.7
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

$ makepkg -s
==> Making package: beets-alternatives 0.10.1-1 (Fri Oct  9 20:23:22 2020)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...
:: beets and beets-git are in conflict. Remove beets-git? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: beets and beets-git are in conflict

I thought that because beets-git 'provides' beets, it should satisfy the dependency of this PKGBUILD. Does that not apply when specifying a package version? If that's true, then how can this dependency/conflict be resolved?