Package Details: bertini 1.6-2

Git Clone URL: https://aur.archlinux.org/bertini.git (read-only, click to copy)
Package Base: bertini
Description: Homotopy continuation solver for systems of polynomial equations
Upstream URL: http://bertini.nd.edu/
Licenses: custom: Bertini license
Submitter: akobel
Maintainer: akobel
Last Packager: akobel
Votes: 2
Popularity: 0.032907
First Submitted: 2016-02-12 07:55 (UTC)
Last Updated: 2022-04-14 21:21 (UTC)

Latest Comments

BachoSeven commented on 2022-08-03 08:48 (UTC)

@akobel I think I must have had those installed, however I now cannot test on the same computer anymore, and it builds fine on another one I have, so I will lyk if there is an issue when I can test it again, but at this point I suspect it was nothing.

akobel commented on 2022-08-02 22:01 (UTC)

@BackoSeven Hm, I don't have byacc installed, yet the build works for me.

What is the message you get that makes you think byacc is missing? Could you double-check whether you have yacc (in the bison package) and flex installed? The are not listed as dependencies because AUR packages always assume the base-devel group to be installed, according to https://wiki.archlinux.org/title/PKGBUILD#makedepends; can you confirm?

BachoSeven commented on 2022-07-21 10:10 (UTC)

@akobel Hi again, I think this is missing byacc as a make dependency, and even after installing that it seems it's failing to build:

/bin/sh ./config/ylwrap src/pParse_flex.l .c src/pParse_flex.c -- : -s -P`basename src/pParse_flex | sed 's,l$,,'` -olex.yy.c
make: *** [Makefile:2282: src/pParse_flex.c] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Makefile:2282: src/ppParse_flex.c] Error 1
updating src/pParse_bison.h
updating src/ppParse_bison.h
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'bertini-1.6-2':
error: packages failed to build: bertini-1.6-2

BachoSeven commented on 2022-04-14 18:11 (UTC)

@akobel Hi, the sha256sums for this package seem to have changed, here is a diff for the current sums:

diff --git a/PKGBUILD b/PKGBUILD
index 71fa548..a82c1de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=('boost' 'mpfr')
 optdepends=('openmpi: multithreading support')
 source=("${url}/BertiniSource_v${pkgver}.tar.gz"
         "${url}/BertiniUsersManual.pdf")
-sha256sums=('b742d4a55623092eb0c46f8ee644aa487e5decf4ad05eb9297306b599795a424'
+sha256sums=('f5f546ca662a05eeee091640e0fba343d5ba94da136d8ed9a7e21668af14230d'
             '017313464d162bb32640858faa0dc40ec8498eee439cb703dc22507baa15394f')

 prepare () {