Package Details: betterspades 0.1.5-3

Git Clone URL: https://aur.archlinux.org/betterspades.git (read-only, click to copy)
Package Base: betterspades
Description: Opensource game client for Ace Of Spades 0.75 protocol
Upstream URL: https://github.com/xtreme8000/betterspades/
Keywords: aceofspades fps game pixel shooter survival
Licenses: GPL3
Submitter: Geeko
Maintainer: Mr.Smith1974
Last Packager: Mr.Smith1974
Votes: 4
Popularity: 0.006963
First Submitted: 2019-07-24 10:51 (UTC)
Last Updated: 2023-09-01 10:38 (UTC)

Latest Comments

Mr.Smith1974 commented on 2023-09-01 10:04 (UTC)

@Ziarnova Hello. I don't know why this behavior occurs.

I already wrote to the developers about this and they did not answer me: https://github.com/xtreme8000/BetterSpades/issues/184

Ziarnova commented on 2023-09-01 08:35 (UTC)

The package cannot be built

In function '_mm_store_ps', inlined from 'glm_vec4_zero' at /home/zeer/.cache/yay/betterspades/src/BetterSpades-0.1.5/build/_deps/cglm-src/src/../include/cglm/vec4.h:178:3, inlined from 'glm_vec4_scale_as' at /home/zeer/.cache/yay/betterspades/src/BetterSpades-0.1.5/build/_deps/cglm-src/src/../include/cglm/vec4.h:459:5, inlined from 'glmc_vec4_scale_as' at /home/zeer/.cache/yay/betterspades/src/BetterSpades-0.1.5/build/_deps/cglm-src/src/vec4.c:128:3: /usr/lib/gcc/x86_64-pc-linux-gnu/13.2.1/include/xmmintrin.h:982:18: error: array subscript '__m128[0]' is partly outside array bounds of 'float[3]' [-Werror=array-bounds=] 982 | (__m128 )__P = __A; | ~~~~~~~~~~~~~~~^~~~~ /home/zeer/.cache/yay/betterspades/src/BetterSpades-0.1.5/build/_deps/cglm-src/src/vec4.c: In function 'glmc_vec4_scale_as': /home/zeer/.cache/yay/betterspades/src/BetterSpades-0.1.5/build/_deps/cglm-src/src/vec4.c:127:42: note: object 'dest' of size [0, 12] 127 | glmc_vec4_scale_as(vec4 v, float s, vec4 dest) { | ~~~~~^~~~ cc1: all warnings being treated as errors make[2]: *** [_deps/cglm-build/CMakeFiles/cglm.dir/build.make:174: _deps/cglm-build/CMakeFiles/cglm.dir/src/vec4.c.o] Error 1 make[1]: *** [CMakeFiles/Makefile2:160: _deps/cglm-build/CMakeFiles/cglm.dir/all] Error 2 make: *** [Makefile:156: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

JimPix commented on 2022-06-20 10:33 (UTC)

Could this be updated? 0.1.4 is quite out of date and banned on a lot of AoS servers.

alborrajo commented on 2021-07-02 12:25 (UTC)

The sha512sum of bsresources.zip is wrong. It should be 83651b4befe06b534299fac03de032466f20ab8010bcb0828e8f67594865726437b527334fd3f048b5ae1939ad0e4d02bf8fd5cff2e23afba7d6e644dd6f5fa7