Package Details: bib2ref 0.1-2

Git Clone URL: https://aur.archlinux.org/bib2ref.git (read-only)
Package Base: bib2ref
Description: Create refer databases from bibtex files.
Upstream URL: http://litcave.rudi.ir/
Licenses: custom:BSD
Submitter: aksr
Maintainer: aksr
Last Packager: aksr
Votes: 0
Popularity: 0.000000
First Submitted: 2014-04-15 10:36
Last Updated: 2015-06-28 08:26

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

aksr commented on 2014-04-17 20:16

sekret: Check this link:
https://wiki.archlinux.org/index.php/AUR#Foo_in_AUR_does_not_compile_when_I_run_makepkg.3B_what_should_I_do.3F

aksr commented on 2014-04-17 20:16

I had a long discussion about this on IRC. It seems that base must be installed with the default installation. After that, AUR demands base-devel group.

sekret commented on 2014-04-17 18:46

On the other hand, I THINK that the need for base-devel is meant for makedepends. E.g. gcc never goes into makedepends. The way I see it is now, that depends should include everything required by the package, but makedepends should only include what's required for building the package, except if it's already in depends and base-devel.

sekret commented on 2014-04-17 18:44

Yes, but still, glibc is a dependency, which is reported by namcap and - most importantly - official packages from the repos also include glibc in the depends line, if the package depends on it, see https://www.archlinux.org/packages/core/x86_64/glibc (Required By). I know there's a contradiction here, which might be supposed to be discussed somewhere.

aksr commented on 2014-04-15 12:05

sekret: Using AUR assumes you have installed 'base-devel' group:
https://wiki.archlinux.org/index.php/AUR#Getting_started

sekret commented on 2014-04-15 11:58

It depends on glibc, please add it to the package.