Package Details: bibus 1.5.2-6

Git Clone URL: https://aur.archlinux.org/bibus.git (read-only)
Package Base: bibus
Description: A bibliographic database that can directly insert references in OpenOffice.org/LibreOffice and generate the bibliographic index.
Upstream URL: http://sourceforge.net/projects/bibus-biblio/
Licenses: GPL
Submitter: mutlu_inek
Maintainer: haawda
Last Packager: haawda
Votes: 45
Popularity: 0.082717
First Submitted: 2007-01-12 03:10
Last Updated: 2017-03-18 22:23

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

machoo02 commented on 2012-11-04 15:14

@Stunts:
I'll disown it today, so it's all yours. Good luck!

HalosGhost commented on 2012-11-04 06:28

Machoo02, Thank you for the update. I can confirm the patch appears unneeded for LO-3.6.3-1.

Stunts commented on 2012-11-03 23:35

@machoo02:
Thank you for updating the package.
My last testing was with LibreOffice-3.6.2-?, and at that time, the patch was required. But now the issue seems to be fixed, which is great.
I should be using bibus/LO extensively for quite a while now, so if nobody else turns up I will volunteer to maintain the package.

machoo02 commented on 2012-11-03 20:52

Apologies about the delay in package update; I did not see comment notices in my email for some reason. I've uploaded a new package version fixing the depends. Regarding the patch: I've tested a variety of functionality, and I've not found anything that does not work as expected. Can you provide a rationale for requiring the patch? I recall that it was necessary to properly finalize documents in prior versions, but with the latest LibreOffice in the repos (3.6.3-1) finalization works as expected.

NOTE: I don't use bibus very frequently anymore, so I do not keep a close eye on development or Libre/OpenOffice integration issues. If anyone would like to take over maintenance of this package, I'd be happy to orphan it and let a more interested party become responsiblie.

HalosGhost commented on 2012-10-25 19:46

machoo02, please update the PKGBUILD to reflect the python rebuild (depends should include python2-pysqlite).

Thank you!

Stunts commented on 2012-10-18 13:18

Also, to the people who cannot get bibus to work with libreoffice after the update, don't forget to lower macro security to at least medium to restore the pipe connection.

Stunts commented on 2012-10-18 11:55

You have to update the PKGBUILD due to the python rebuild.
python-pysqlite -> python2-pysqlite

Also please consider applying the patch recommended by crocowhile.

crocowhile commented on 2012-09-03 15:23

Can you please make sure that PKGBUILD will patch using the following patch?

http://sourceforge.net/tracker/download.php?group_id=110943&atid=657834&file_id=415374&aid=3323127

Otherwise bibus doesn't really work with the recent Libreoffice.

machoo02 commented on 2012-04-21 16:39

Updated with fix.

Stunts commented on 2012-03-29 10:48

Libreoffice 3.5.1 broke bibus again.
Fix is here.
https://bbs.archlinux.org/viewtopic.php?pid=1079401#p1079401
You should update the PKGBUILD accordingly.
Thanks.