Package Details: biglybt-extreme-mod 1.5.0.0b-1

Git Clone URL: https://aur.archlinux.org/biglybt-extreme-mod.git (read-only)
Package Base: biglybt-extreme-mod
Description: A modded version of the BiglyBT client with multiple spoofing capabilities
Upstream URL: http://www.sb-innovation.de/f41/
Licenses: GPL3
Submitter: Det
Maintainer: Det
Last Packager: Det
Votes: 2
Popularity: 0.333154
First Submitted: 2017-12-26 17:25
Last Updated: 2018-04-20 02:51

Latest Comments

moham_96 commented on 2018-02-10 16:34

Yes it works, thank you

Det commented on 2018-02-10 08:43

Should work now.

moham_96 commented on 2018-02-10 06:07

I still get a failed build with the following error:

don't need JNA

not wayland

No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.8 and at most 1.9.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

I use java 9:

sudo archlinux-java status

Available Java environments:

java-8-openjdk/jre

java-9-openjdk (default)

Det commented on 2018-02-09 12:05

Yes, the build now seems to work even without the export, but:

1) OpenJDK 9 doesn't have the JRE subdirectory, because they were merged in JRE/JDK 9.

2) You check for directories with the -d flag:

0 ✓ 13:33:21 /usr/lib/jvm/java-8-openjdk

$ ls -d *

bin include jre lib

3) Do you know how to use archlinux-java? If your default's 8, you should get:

$ biglybt-extreme-mod

Starting BiglyBT...

Suitable java version found [java = java 1.8.0_162]

Error: A JNI error has occurred, please check your installation and try again

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/biglybt/platform/JavaBitMode has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

moham_96 commented on 2018-02-09 04:39

Your check in prepare() is not returning OpenJDK because it doesn't have a JRE subdirectory

ls -la /usr/lib/jvm/java-9-openjdk

total 20

drwxr-xr-x 4 root root 4096 Jan 19 07:41 .

drwxr-xr-x 4 root root 4096 Jan 19 07:53 ..

drwxr-xr-x 2 root root 4096 Jan 19 07:41 bin

lrwxrwxrwx 1 root root 18 Oct 7 20:12 conf -> /etc/java9-openjdk lrwxrwxrwx 1 root root 33 Oct 7 20:12 legal -> /usr/share/licenses/java9-openjdk

drwxr-xr-x 5 root root 4096 Jan 19 07:41 lib

lrwxrwxrwx 1 root root 14 Oct 7 20:12 man -> /usr/share/man

-rw-r--r-- 1 root root 1169 Oct 7 20:12 release

also, why are you checking for Java 9 and 10 only? this app works fine with version 8