Package Details: bijiben-git 3.17.2.r2.g5b079d0-1

Git Clone URL: https://aur.archlinux.org/bijiben-git.git (read-only)
Package Base: bijiben-git
Description: Write out notes, every detail matters
Upstream URL: https://wiki.gnome.org/Apps/Bijiben
Licenses: GPL
Conflicts: bijiben
Provides: bijiben=3.17.2
Submitter: pictuga
Maintainer: yoseforb
Last Packager: yoseforb
Votes: 7
Popularity: 0.000000
First Submitted: 2012-11-18 18:12
Last Updated: 2015-06-09 08:46

Latest Comments

yoseforb commented on 2013-07-30 00:39

Please, add '--disable-static' flag to autogen.sh:
http://www.fpaste.org/28847/75144775/

josephgbr commented on 2013-07-03 17:58

:) Ok, thanks for your contribution.

pictuga commented on 2013-07-03 17:57

well, I disowned the package. I no longer use it, and @josephgbr seems to be more fit to take care of it ;)

josephgbr commented on 2013-07-02 10:33

This git repository has a submodule, libgd[1], which requires to called in the pkgbuild. I suggest that you take a look in @grawity's suggestion on how to call it, in package gnome-music-git.

[1] https://git.gnome.org/browse/bijiben/tree/.gitmodules

pictuga commented on 2013-06-03 17:56

done

josephgbr commented on 2013-06-01 21:04

Looks like 'yelp-tools' is required as 'makedepends'.

Checking for required M4 macros...
yelp.m4 not found
***Error***: some autoconf macros required to build bijiben
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?

jswagner commented on 2013-06-01 20:59

Checking for required M4 macros...
yelp.m4 not found
***Error***: some autoconf macros required to build bijiben
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?

==> ERROR: A failure occurred in build().
Aborting...
:: bijiben-git cleaned

josephgbr commented on 2013-05-01 13:36

Awesome, thanks!

pictuga commented on 2013-05-01 10:43

@josephgbr it's done. I cleaned it up a little, based on the PKGBUILD from official repos.

josephgbr commented on 2013-05-01 04:32

Please update the PKGBUILD syntax to pacman 4.1 - my suggestion: http://paste.archlinux-br.org/2148

pictuga commented on 2013-04-06 12:57

actually this PKGBUILD and [gnome-unstable]'s are not the same. we can see [gnome-unstable]'s at http://permalink.gmane.org/gmane.linux.arch.scm/126860. I'm not using [gnome-unstable] so I can't test, sorry.

0rAX0 commented on 2013-04-06 10:29

Is anyone getting a segfault with this(or the one from [gnome-unstable])? It crashes as soon as I press 'New'. :(

pictuga commented on 2013-03-09 21:52

well, looks like they made another release with the 3.7.7 requirement…

pictuga commented on 2013-03-09 21:51

creating another package with (dev for now) releases (like 3.7.90) could be a solution (the last commit-tagged release is BIJIBEN_3_7_90, which is older than the gtk 3.7.7 requirement) see https://git.gnome.org/browse/bijiben/tag/?id=BIJIBEN_3_7_90

josephgbr commented on 2013-03-09 19:13

Actually this hash is from the commit that introduced the requirement gtk 3.7.7, so probably its parent is better. With that, the command would be:

build() {
(...)
cd "${srcdir}/${_gitname}-build"
git checkout c8da5b5559129ef6755ad037ff7e5a3133f688d6
(...)
}

obs.: bijiben commit logs https://git.gnome.org/browse/bijiben/log/

Thanks for the info.

pictuga commented on 2013-03-09 19:07

@josephgbr
add "git checkout HASH" after the "cd ${srcdir}/${_gitname}-build" line. and replace HASH with the git commit's hash, which is 547bfd1cd4f8618ed4b1a263b78fd80151e8eabb I think (you'd better check).

josephgbr commented on 2013-03-09 14:02

@pictuga:

Just for curiosity, do you know what would be the command line required to use a previous commit of this module? (obs.: gtk 3.7.7 requirement was introduced in 2013-02-18 with message "windowBase: Use GdStack rather GtkNoteBook")

pictuga commented on 2013-03-09 13:23

yes. for now going back to an older commit should solve the problem.

josephgbr commented on 2013-03-09 10:39

That's expected. GNOME is about to release a new version of GTK that will meet this requirement

pictuga commented on 2013-03-08 22:26

no longer builds, cause it now requires gtk+ 3.7.7...

pictuga commented on 2012-12-14 09:29

added gd

josephgbr commented on 2012-12-14 02:00

Talking about namcap, "bijiben-git E: Dependency gd detected and not included (libraries ['usr/lib/libgd.so'] needed in files ['usr/bin/bijiben'])"

pictuga commented on 2012-12-13 15:47

added "update-desktop-database -q" to register mimetype (suggested by namcap)

josephgbr commented on 2012-12-12 22:26

sorry, my suggestion was not that accurate. I should have mentioned './autogen.sh' instead of './configure', and 'bijiben' instead of '$pkgname'. Thnkas for the fix.

pictuga commented on 2012-12-12 21:25

fixed libexec ;)

pictuga commented on 2012-12-12 15:47

i'll do that as soon as i figure out where to add the given parameter in the PKGBUILD ;) it's my first one, so i'm still unsure about where to add it, since ./configure ain't called so far, just the .sh.

josephgbr commented on 2012-12-09 16:13

Can you add to ./configure the flag "--libexec=/usr/lib/$pkgname" ? Because libexec should not be in /usr/lib/libexec, according to Arch Packaging Standards. Btw, thanks for the PKGBUILD.

pictuga commented on 2012-11-18 18:55

updated with fixed icon

pictuga commented on 2012-11-18 18:28

btw the program is still in early stage of dvlpt. So there's a bunch of bugs.

pictuga commented on 2012-11-18 18:14

NB. This is my first PKGBUILD, so it's not perfect. I mostly changed gnome-shell-git's. I'm not sure about dependencies.