Package Details: bin32-firefox 76.0.1-1

Git Clone URL: https://aur.archlinux.org/bin32-firefox.git (read-only, click to copy)
Package Base: bin32-firefox
Description: Standalone web browser from mozilla.org - 32bit version for 64bit systems
Upstream URL: https://www.mozilla.org/projects/firefox
Licenses: GPL, MPL, LGPL
Submitter: c0nd0r
Maintainer: TheGoliath
Last Packager: TheGoliath
Votes: 62
Popularity: 0.000001
First Submitted: 2011-12-24 19:07
Last Updated: 2020-05-09 10:57

Dependencies (8)

Required by (1)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3

Anonymo commented on 2010-06-16 16:18

Needs lib32-alsa-lib as dependancy

ricardofunke commented on 2010-06-10 21:44

I installed this packages;
- lib32-libcanberra
- lib32-gvfs

Now, just these messages ares displaying:

Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado
Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

'Cause I can't find packages for libgvfsdbus.so and libgnomebreakpad.so

ricardofunke commented on 2010-06-10 21:13

It's working very well, but still display the messages above:


Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so


what's pastebin?

ricardofunke commented on 2010-06-10 21:08

The following error ocurred, firefox opened but took


~]$ firefox32
Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

td123 commented on 2010-06-10 20:20

Can you also install lib32-gtk-engines and try again?
I will update the dependencies once you get it running.

P.S. We have a pastebin for a reason :)

td123 commented on 2010-06-10 20:19

Can you also install lib32-gtk-engines and try again?

P.S. We have a pastebin for a reason :)

ricardofunke commented on 2010-06-10 20:04

The following error ocurred, firefox opened but took


~]$ firefox32
Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "/opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so": /opt/lib32/usr/lib/gtk-2.0/modules/libgnomebreakpad.so: cannot open shared object file: Arquivo ou diretório não encontrado

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox32-bin:6508): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

td123 commented on 2010-06-10 18:00

could you install lib32-alsa-lib-fixed and see if it works?

ricardofunke commented on 2010-06-10 17:51

Not working,

when I run on terminal:

~]$ firefox32
/opt/firefox32/firefox32-bin: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64