Package Details: bioperl-live-git 20161203-1

Git Clone URL: https://aur.archlinux.org/bioperl-live-git.git (read-only, click to copy)
Package Base: bioperl-live-git
Description: Perl modules for bioinformatics applications.
Upstream URL: http://www.bioperl.org
Licenses: GPL, PerlArtistic
Submitter: td123
Maintainer: None
Last Packager: Ordoban
Votes: 1
Popularity: 0.000000
First Submitted: 2010-05-23 20:30 (UTC)
Last Updated: 2017-01-04 08:04 (UTC)

Latest Comments

micwoj92 commented on 2021-04-27 07:11 (UTC)

Hello, could you modernize this PKGBUILD?

jnbek commented on 2016-03-19 22:22 (UTC)

I've tried to get this package working but it's just not happening, I'm going to release this to the wild and hope for the best.

m.gruenstaeudl commented on 2015-08-11 07:52 (UTC)

Another error occurs when yaourt attempts to build the bioperl package: ==> Building and installing package ==> Making package: bioperl-live-git 20100604-1 (Tue Aug 11 09:48:09 CEST 2015) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... ==> Extracting sources... ==> Entering fakeroot environment... ==> Starting package()... ==> Getting sources... Cloning into 'bioperl-live'... remote: Counting objects: 104740, done. remote: Total 104740 (delta 0), reused 0 (delta 0), pack-reused 104740 Receiving objects: 100% (104740/104740), 143.09 MiB | 10.22 MiB/s, done. Resolving deltas: 100% (78899/78899), done. Checking connectivity... done. ==> GIT checkout done or server timeout ==> Starting make... Can't locate Bio/Root/Build.pm in @INC (you may need to install the Bio::Root::Build module) (@INC contains: . /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at Build.PL line 14. BEGIN failed--compilation aborted at Build.PL line 14. ==> ERROR: A failure occurred in package(). Aborting... ==> ERROR: Makepkg was unable to build bioperl-live-git. ==> Restart building bioperl-live-git ? [y/N] ==> ----------------------------------------- ==>

m.gruenstaeudl commented on 2015-08-11 07:48 (UTC)

The below error can be resolved by editing the PKGBUILD and replacing "build()" with "package()".

m.gruenstaeudl commented on 2015-08-10 15:21 (UTC)

Installation via yaourt fails with the following error message: thatsme ~ $ yaourt -S bioperl-live-git --noconfirm ==> Downloading bioperl-live-git PKGBUILD from AUR... x .SRCINFO x PKGBUILD bioperl-live-git 20100604-1 (2015-06-16 19:56) ( Unsupported package: Potentially dangerous ! ) ==> bioperl-live-git dependencies: - perl (already installed) - perl-io-string (already installed) - perl-data-stag (already installed) - git (already installed) ==> Continue building bioperl-live-git ? [Y/n] ==> ------------------------------------------ ==> ==> Building and installing package ==> ERROR: Missing package() function in /tmp/yaourt-tmp-thatsme/aur-bioperl-live-git/./PKGBUILD ==> ERROR: Makepkg was unable to build bioperl-live-git. ==> Restart building bioperl-live-git ? [y/N] ==> ----------------------------------------- ==>