Package Details: birdfont 2.26.0-1

Git Clone URL: https://aur.archlinux.org/birdfont.git (read-only)
Package Base: birdfont
Description: A free font editor that lets you create vector graphics and export TTF, EOT & SVG fonts
Upstream URL: https://birdfont.org/
Keywords: editor EOT font SVG TTF
Licenses: GPL3
Submitter: MatejLach
Maintainer: lostkhaos
Last Packager: lostkhaos
Votes: 26
Popularity: 0.000000
First Submitted: 2013-09-13 20:20
Last Updated: 2019-06-17 15:45

Latest Comments

1 2 3 Next › Last »

Altay commented on 2019-09-16 15:02

Fails to install.

libbirdfont/SettingsDisplay.vala:32.2-32.23: error: Creation method of abstract class cannot be public. public SettingsDisplay () {

Compilation failed: 1 error(s), 114 warning(s) Error: sh -c "valac -C --vapidir=./ --basedir build/libbirdfont/ --enable-experimental --library libbirdfont -H build/libbirdfont/birdfont.h libbirdfont/.vala libbirdfont/OpenFontFormat/.vala libbirdfont/Renderer/*.vala --pkg posix --pkg gee-0.8 --pkg gio-2.0 --pkg cairo --pkg xmlbird --pkg libbirdgems --pkg sqlite3 --pkg gdk-pixbuf-2.0 "

lostkhaos commented on 2019-06-17 15:46

Hey all, I just pushed an update to get this back up to 2.26. It looks like there's a 3.x version as well, but it depends on flatpak.

djringjr commented on 2019-05-12 16:01

From the developer.

Johan Mattsson

Hi. I believe this bug has been fixed in later versions of Birdfont. Try upgrading to 2.26. Cheers

djringjr commented on 2019-05-12 14:58

Won't install.

birdfont/GtkWindow.vala:201.30-201.50: error: Argument 1: Cannot convert from void BirdFont.GtkWindow.dump_clipboard_target (Gtk.Clipboard, Gdk.Atom[])' tovoid Gtk.ClipboardTargetsReceivedFunc (Gtk.Clipboard, Gdk.Atom[]?)'

Compilation failed: 1 error(s), 23 warning(s) Error: sh -c "valac -C --vapidir=./ --basedir build/birdfont/ --enable-experimental birdfont/*.vala --vapidir=./ --pkg gee-0.8 --pkg gio-2.0 --pkg cairo --pkg libsoup-2.4 --pkg gdk-pixbuf-2.0 --pkg webkit2gtk-4.0 --pkg libnotify --pkg xmlbird --pkg libbirdfont " ==> ERROR: A failure occurred in build(). Aborting... Error making: birdfont

jose1711 commented on 2019-03-25 06:49

only bumped version to 2.26 and it built fine for me

drankinatty commented on 2018-04-22 19:39

birdfont/Main.vala:34.2-34.37: warning: Access to static member `BirdFont.BirdFont.load_font_from_command_line' with an instance reference birdfont.load_font_from_command_line (); ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Compilation failed: 1 error(s), 23 warning(s) Error: sh -c "valac -C --vapidir=./ --basedir build/birdfont/ --enable-experimental birdfont/*.vala --vapidir=./ --pkg gee-0.8 --pkg gio-2.0 --pkg cairo --pkg libsoup-2.4 --pkg gdk-pixbuf-2.0 --pkg webkit2gtk-4.0 --pkg libnotify --pkg xmlbird --pkg libbirdfont " ==> ERROR: A failure occurred in build().

SunRed commented on 2016-07-04 13:26

@felix.s I will see what I can do.

felix.s commented on 2016-07-04 09:48

You could add an opt-dependency on unicode-character-database from [extra] and add a patch for Birdfont to look for the database in the appropriate directory.

SunRed commented on 2016-05-02 08:53

@ShalokShalom eh, it's right there: https://aur.archlinux.org/cgit/aur.git/tree/birdfont.install?h=birdfont

ShalokShalom commented on 2016-05-01 14:07

Where is the .install file?