Package Details: bisq-git 1.0.0.r1.g60826a11e-1

Git Clone URL: https://aur.archlinux.org/bisq-git.git (read-only)
Package Base: bisq-git
Description: Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
Upstream URL: https://bisq.network
Licenses: AGPL3
Conflicts: bisq, bisq-bin
Submitter: dmp1ce
Maintainer: dmp1ce (freimair)
Last Packager: freimair
Votes: 8
Popularity: 0.020151
First Submitted: 2017-07-08 03:32
Last Updated: 2019-04-15 16:27

Dependencies (5)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

freimair commented on 2019-04-16 19:53

I removed the out-of-date flag since this is the git build and it always builds the latest version regardless of which version is shown for the package.

fbrennan commented on 2018-11-26 09:26

Unfortunately, this package is junk currently.

Error: Could not find or load main class bisq.desktop.app.BisqAppMain Caused by: java.lang.ClassNotFoundException: bisq.desktop.app.BisqAppMain

is the error I always get; attempting to launch from the included .desktop file results in the same.

Fortunately, the package bisq-bin works just fine. Don't waste your time with this package until it's updated.

dmp1ce commented on 2018-10-24 19:16

@JZA, Bisq developers switch from JDK 8 to JDK 10 from what I can tell. https://github.com/bisq-network/bisq/issues/1729

You will need to install JDK 10 in order to build this package. I tried to specify the JDK 10 for building without setting JDK 10 to default java runtime. I believe you will need to set your java runtime in order to run Bisq however. I recommend running archlinux-java set java-10-openjdk to make Java 10 default on your system if you can. This may effect other java applications on your system. For more information on Java see the wiki page: https://wiki.archlinux.org/index.php/Java

I was also able to run export PATH="/usr/lib/jvm/java-10-openjdk/bin/:$PATH"; bisq-desktop while having Java 8 as my default.

JZA commented on 2018-10-24 15:28

Had the following errors while building. ``` FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':common:compileJava'.

    Could not target platform: 'Java SE 10' using tool chain: 'JDK 8 (1.8)'.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0. Use '--warning-mode all' to show the individual deprecation warnings. See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 1m 39s 4 actionable tasks: 4 executed ```

dmp1ce commented on 2018-09-12 15:52

I see. Thank you for the update @qKUqm3wtY4

qKUqm3wtY4 commented on 2018-09-12 07:33

@dmp1ce Thanks for adding a snap onto snapcraft!

I did go back and test the build again, but it's still broken. I posted the error on github: https://github.com/bisq-network/bisq/issues/1677

EDIT: Install failed simply because I had jdk10 installed and it was trying to use that instead of jdk8 - it worked once I uninstalled jdk10.

dmp1ce commented on 2018-09-10 13:58

There was some upstream changes which broke the build. The build should work now. Please report other issues.

I created a Snap for Bisq which is here: https://snapcraft.io/bisq-desktop

I'll look into a flatpak as well.

qKUqm3wtY4 commented on 2018-09-10 07:27

The build fails. It has been 18 days since you posted that the package would be updated. If you aren't going to keep this updated, would you mind just creating a stable flatpak so that anyone can install it on any Linux distro without issue? Either way, I appreciate you and all of the other devs.

freimair commented on 2018-08-23 07:48

I am onto updating the package. Might take a few days though.

stevenroose commented on 2018-05-29 14:51

/usr/bin/pacman: unrecognized option '--color never' ==> ERROR: 'pacman' failed to install missing dependencies.