Package Details: bitbake 1.30-6

Git Clone URL: https://aur.archlinux.org/bitbake.git (read-only)
Package Base: bitbake
Description: Build tool executing tasks and managing metadata.
Upstream URL: http://openembedded.org
Licenses: GPL2
Submitter: ftonello
Maintainer: ftonello
Last Packager: ftonello
Votes: 1
Popularity: 0.061906
First Submitted: 2016-07-21 14:48
Last Updated: 2016-10-21 09:51

Latest Comments

ftonello commented on 2016-11-28 15:39

These files and dependencies are only necessary if you want to use bitbake in a build system. In that case, you shouldn't use this package.

This package is usefull for other bitbake related tasks, suck as PR server and others.

AndyRTR commented on 2016-11-04 18:59

pkg doens't work. PKGBUILD needs additional wget and git packages to makedepends. The install msg seems not to be enough. Building asteroidos I get an error to set BBPATH. Additionally some files are missing:
IOError: [Errno 2] file conf/bitbake.conf not found in /usr/lib/python2.7/site-packages

I suggest to either fix this or even jump to 1.32 based on python 3.x.

ftonello commented on 2016-10-21 09:50

No, that's correct because they have updated bitbake package without bumping the version since it is a fix in the selftest script, I guess. I have updated now. Thanks.

DacodaS commented on 2016-10-14 23:37

When validating with the md5sums it fails. Plz. Specifically, the md5 of the 1.30.zip file I get is 76e61f7efbabb38caf5f3531e87a988f whereas it looks like it's looking for 78f913fa7ca7674705b05fb04d1067ce. Am I crazy?

ftonello commented on 2016-09-08 08:22

Yes, but that is actually a bug in bitbake, hopefully they fix that. If you want to build anyway, just remove the check() function.

sl1pkn07 commented on 2016-09-07 21:06

https://sl1pkn07.wtf/paste/view/8fe2a8aa

ftonello commented on 2016-09-06 14:37

I fixed both, thanks.
Apparently this newer 1.30 version is failing to build due to some cups.org failure.

Splashy commented on 2016-09-06 14:26

Md5sums is outdated
and pythonpath should be equal to:
PYTHONPATH=`pwd`/../lib:`pwd`/../lib/bb

ftonello commented on 2016-08-23 13:29

Try adding `pwd`/../lib/bb to PYTHONPATH to the check() function, example:
PYTHONPATH=`pwd`/../lib:`pwd`/../lib/bb

Let me know if it fixes, if it works, then I can fix this package.

Girafferson commented on 2016-08-22 08:12

I get this error when installing on my laptop and desktop running manjaro 64-bit. When I look this issue up people say to use python 2 instead of 3 but I've been unable to get yaourt to use it.
http://pastebin.com/FAifhBuk

ftonello commented on 2016-07-22 14:37

Fixed.

ftonello commented on 2016-07-22 13:55

Scimmia, fair enough. Thanks.

Scimmia commented on 2016-07-22 13:34

Just like all of the other deps, make a package for it.

ftonello commented on 2016-07-22 13:27

Scimmia, can you please tell me how you would do it?

Scimmia commented on 2016-07-22 13:04

Using sudo pip here is very, very, VERY wrong.

ftonello commented on 2016-07-22 10:56

Hi sl1pkn07,

I've pushed a new release of this package that fixes this issue. Thanks for reporting.

Felipe

sl1pkn07 commented on 2016-07-21 19:27

Copying codegen.egg-info to /usr/lib/python2.7/site-packages/codegen-1.0-py2.7.egg-info
error: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/codegen-1.0-py2.7.egg-info'

----------------------------------------
Command "/usr/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-r3Tiqc/codegen/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-YLeHMk-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-r3Tiqc/codegen/