Package Details: bitcoin-classic-daemon-git git-1

Git Clone URL: https://aur.archlinux.org/bitcoin-classic-daemon-git.git (read-only)
Package Base: bitcoin-classic-daemon-git
Description: Bitcoin Classic versions of bitcoind, bitcoin-cli, and bitcoin-tx
Upstream URL: https://bitcoinclassic.com/
Keywords: bitcoin bitcoin-classic crytpcurrency
Licenses: MIT
Conflicts: bitcoin-cli, bitcoin-daemon, bitcoin-tx
Provides: bitcoin-cli, bitcoin-daemon, bitcoin-tx
Submitter: TomZander
Maintainer: TomZander
Last Packager: TomZander
Votes: 2
Popularity: 0.002148
First Submitted: 2017-01-11 12:16
Last Updated: 2017-05-09 08:22

Latest Comments

tuxayo commented on 2016-10-02 21:15

Thanks @uncle for orphaning, now someone else can success you. Thanks for having created this package.

@all What work is required to maintain this package? point to master (because it's a *-git package right?) and try to build?

tuxayo commented on 2016-09-23 19:42

Is this package still maintained?

The version of this package is a commit dating from march 7:
https://github.com/bitcoinclassic/bitcoinclassic/commit/d10f990

Version has 1.1.1 been released:
https://github.com/bitcoinclassic/bitcoinclassic/releases/tag/v1.1.1

Spider.007 commented on 2016-03-15 17:46

This package is missing a dependency on 'db' and 'libevent'. Also; arch=('any') is not supposed to be used in packages that contain binaries, use arch=('i686' 'x86_64') for multi-arch instead

uncle commented on 2016-02-15 20:08

See the discussion regarding the DB issue on GitHub in the following link, for reasons why (or why not) to use Berkeley DB 4.8:
https://github.com/bitcoin/bitcoin/issues/6253
TL;DR - Backwards compatibility, and compatibility with official binaries.

uncle commented on 2016-02-15 19:52

If you want to build with wallet, use --with-incompatible-bdb or download the AUR package "db4.8"
https://aur.archlinux.org/packages/db4.8/
I will consider adding --with-incompatible-bdb to the PKGBUILD, it is already in my "bitcoin-classic-git" package.

tuxayo commented on 2016-02-14 20:01

Does anyone else had to `--disable-wallet` to be able to build?

I had this error:

checking for Berkeley DB C++ headers... default
configure: error: Found Berkeley DB other than 4.8, required for portable wallets (--with-incompatible-bdb to ignore or --disable-wallet to disable wallet functionality)

uncle commented on 2016-02-04 19:00

@ERamseth one of the nice things about git packages, is most of them update automatically, regardless of the version listed. If the pkgbuild contains a section called "pkgver" after the sources, than it automatically updates. For example, in this package, it is:
"pkgver() {
cd "$srcdir/bitcoinclassic"
git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}"
If you run yaourt with the --devel flag when performing an update it will update all git packages on your system, for example:
"yaourt -Syua --devel"

ERamseth commented on 2016-02-04 13:36

@uncle thanks! And thanks for maintaining it! (ps, beta 2 is released today... trivial to update via pkgbuild edits, but I wasn't sure if you'd seen the release)

uncle commented on 2016-02-03 07:59

@ERamseth I implemented your requests, sorry about the make -j, I had added "-j$(nproc)" while testing the package on my machine, to speed up compiling by using all cores, but had meant to remove it as the package is aimed towards servers and low-powered machines. Obviously I removed the "$(nproc)" but missed the "-j" :-D Enjoy the package!

ERamseth commented on 2016-02-02 23:45

please change "make -j" to "make" and add armv7h to supported architectures.