Package Details: bitcoin-git 1:0.9.0rc2.3425.g86cfd23-1

Git Clone URL: https://aur.archlinux.org/bitcoin-git.git (read-only)
Package Base: bitcoin-git
Description: Bitcoin is a peer-to-peer network based digital currency. This package provides both the GUI QT4 and daemon clients.
Upstream URL: http://www.bitcoin.org/
Licenses: MIT
Conflicts: bitcoin, bitcoin-bin, bitcoin-daemon, bitcoin-qt, bitcoind
Provides: bitcoin, bitcoin-qt, bitcoind
Submitter: krevedko
Maintainer: Raansu
Last Packager: Raansu
Votes: 16
Popularity: 0.091283
First Submitted: 2011-06-19 19:13
Last Updated: 2015-08-02 08:34

Latest Comments

Raansu commented on 2015-08-02 05:22

UPDATED TO AUR4!!!

Let me know if there are any issues!

Raansu commented on 2015-08-01 14:33

I'm going to take over just to keep bitcoin-git from disappearing when AUR4 is fully switched on.

@Nothing4You I can make you a co-maintainer if you so wish, just let me know.

Raansu commented on 2015-08-01 13:23

@Naypam I have updated the db4.8 package, everything 'should' work now.

Naypam commented on 2015-04-24 10:58

@Nothing4You: The db4.8 package is completely broken.

Naypam commented on 2015-04-24 10:57

I was told that "qrencode" was an orphan after installation while it's necessary for the running of the node. Not sure if that's an issue here or not?

Nothing4You commented on 2014-04-14 08:40

You need to learn how to use the AUR. If the dependencies are not available through pacman it usually means they're in the AUR.
You have to install db4.8 from the AUR: https://aur.archlinux.org/packages/db4.8

krevedko commented on 2014-04-14 07:15

$ makepkg -s
==> Making package: bitcoin-git 1:0.8.2.716.g7c4c207-1 (Mon Apr 14 11:14:35 MSK 2014)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: db4.8
==> ERROR: 'pacman' failed to install missing dependencies.

Nothing4You commented on 2014-04-12 15:12

Sorry, couldn't get back to you earlier.
You seem to be using an old PKGBUILD.
Please download the package again.

Nothing4You commented on 2014-04-10 06:07

Ah, somehow I missed that new autogen, I'll fix it later today.

krevedko commented on 2014-04-10 05:36

sed: makefile.unix: No such file or directory
By now, you need to call autogen.sh, configure, make, make install.

Nothing4You commented on 2014-04-09 21:35

Couldn't take a closer look as I'm not on arch right now, from a simple look at the bitcoin build instructions I can't see why this wouldn't work anymore, care to explain?

nfnty commented on 2013-09-08 08:02

Unable to build this package:

==> Starting build()...
==> Patching makefile.unix...
sed: can't read makefile.unix: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

Nothing4You commented on 2013-03-19 22:29

as qt5 is out and bitcoin doesn't yet support qt5 qmake-qt4 should be used instead of qmake

krevedko commented on 2012-06-12 15:42

I've removed "obsoleted"-flag; works for me.

krevedko commented on 2011-10-28 22:22

updated to 0.5.0 branch: wxgtk-2.9 -> qt4, shallow git-clone to save some bandwidth