Package Details: bitlbee-discord-git 0.4.3-1

Git Clone URL: https://aur.archlinux.org/bitlbee-discord-git.git (read-only, click to copy)
Package Base: bitlbee-discord-git
Description: Bitlbee plugin for Discord
Upstream URL: https://github.com/sm00th/bitlbee-discord
Keywords: bitlbee discord plugin
Licenses: GPL
Submitter: Ranndom
Maintainer: sm00th
Last Packager: sm00th
Votes: 8
Popularity: 0.25
First Submitted: 2015-11-27 07:03 (UTC)
Last Updated: 2020-04-07 17:28 (UTC)

Latest Comments

dpriskorn commented on 2020-09-13 05:54 (UTC) (edited on 2020-09-13 05:54 (UTC) by dpriskorn)

I get this error

configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating doc/Makefile
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
make  all-recursive
make[1]: Entering directory '/home/egil/.cache/yay/bitlbee-discord-git/src/bitlbee-discord'
Making all in src
make[2]: Entering directory '/home/egil/.cache/yay/bitlbee-discord-git/src/bitlbee-discord/src'
  CC       discord_la-discord-handlers.lo
  CC       discord_la-discord.lo
../libtool: line 3456: -v: command not found
  CC       discord_la-discord-http.lo
../libtool: line 3456: -v: command not found
  CC       discord_la-discord-util.lo
../libtool: line 3456: -v: command not found
  CC       discord_la-discord-websockets.lo
../libtool: line 3456: -v: command not found
../libtool: line 3456: -v: command not found
  CCLD     discord.la
libtool:   error: 'discord_la-discord.lo' is not a valid libtool object
make[2]: *** [Makefile:448: discord.la] Error 1
make[2]: Leaving directory '/home/egil/.cache/yay/bitlbee-discord-git/src/bitlbee-discord/src'
make[1]: *** [Makefile:426: all-recursive] Error 1
make[1]: Leaving directory '/home/egil/.cache/yay/bitlbee-discord-git/src/bitlbee-discord'
make: *** [Makefile:358: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
error making: bitlbee-discord-git

ChrisLane commented on 2020-04-07 16:59 (UTC)

Since you're tagging releases on GitHub, could you update the pkgver() to include those version numbers in the package version? Also, a version bump would be appreciated! Thanks

sm00th commented on 2017-09-10 18:15 (UTC)

> Can you add the /usr/share/bitlbee/discord-help.txt file please? This should be fixed now.

mickael9 commented on 2017-09-10 16:30 (UTC) (edited on 2017-09-10 16:31 (UTC) by mickael9)

Can you add the /usr/share/bitlbee/discord-help.txt file please? https://github.com/sm00th/bitlbee-discord/commit/27d4c5849e9da807ac5351aa3f748e0fae67b0e4

commented on 2017-05-19 23:45 (UTC)

armv6h and armv7h should be binary-compatible. It crashes bitlbee as soon as I activate my account with 'account discord on' on my RPi gen 1 (armv6h) though... Will try to debug.

ChrisLane commented on 2017-03-17 01:22 (UTC) (edited on 2017-03-17 14:30 (UTC) by ChrisLane)

Seems to have built correctly, will update tomorrow when I've checked that it works. Edit: All works! Thanks a lot.

sm00th commented on 2017-03-16 17:42 (UTC)

> Could you please make this available for the 'aarch64' architecture? Added armv7h and aarch64. I don't have a aarch64 board atm, could you please verify that it actually builds/works on aarch64?

ChrisLane commented on 2017-03-16 16:40 (UTC)

Could you please make this available for the 'aarch64' architecture?

sm00th commented on 2017-01-20 20:48 (UTC)

> Might also want to remove unneeded dependencies from the .SRCINFO file as well, they mess a bit with AUR helpers as it is. Ah, thats why they were still shown as dependencies on this page. I'm not that well versed in arch packaging. Thank you, removed.

Roliga commented on 2017-01-20 19:19 (UTC)

Might also want to remove unneeded dependencies from the .SRCINFO file as well, they mess a bit with AUR helpers as it is.

sm00th commented on 2017-01-07 09:44 (UTC)

> libtool, autoconf and automake not need because is provided by base-devel group Thanks, removed those from pkgbuild. > The disconnect issue has been happening to me, yeah. Fairly crippling bug, renders this unusable, I miss out on a lot of chat. I am not sure whether you are both talking about the same disconnect issue. Occasional disconnects are normal, disconnects while connecting could be cause by you bitlbee server's IP not being whitelisted on discord. The only crippling disconnects I am aware of is the "Failed to read data" ones that have been fixed for a while https://github.com/sm00th/bitlbee-discord/issues/57. Anyway I'd like to keep this comments section strictly package-related so if you have any questions or bug reports about bitlbee-discord itself it should be directed to github issue tracker.

Aelius commented on 2017-01-07 00:31 (UTC)

The disconnect issue has been happening to me, yeah. Fairly crippling bug, renders this unusable, I miss out on a lot of chat.

sl1pkn07 commented on 2017-01-06 23:16 (UTC)

libtool, autoconf and automake not need because is provided by base-devel group (https://wiki.archlinux.org/index.php/Arch_User_Repository)

sl1pkn07 commented on 2017-01-06 23:02 (UTC)

‎[23:59:55] ‎<‎root‎>‎ discord - Logging in: Remote host is closing websocket connection ‎[23:59:55] ‎<‎root‎>‎ discord - Logging in: Signing off.. ‎[23:59:55] ‎<‎root‎>‎ discord - Logging in: Reconnecting in 5 seconds.. this is normal?

Aelius commented on 2016-12-16 23:00 (UTC)

http://sprunge.us/HhUR Updated PKGBUILD @sm00th you should request this be orphaned and take over

mkaito commented on 2016-12-14 23:56 (UTC)

This really needs an update. Is the maintainer MIA?

sm00th commented on 2016-05-12 08:59 (UTC)

libwebsockets dependency is no longer needed, you can remove it from the package.

sm00th commented on 2016-04-10 07:36 (UTC)

switching to stable libwebsockets might be a good idea since they break things quite often

saironiq commented on 2016-04-08 00:32 (UTC) (edited on 2016-04-08 00:32 (UTC) by saironiq)

changing the dependency to just "libwebsockets" (1.6, not git head) and dropping the variables passed to ./configure works.

Sightline commented on 2016-02-03 23:47 (UTC)

Could you take a look at: https://github.com/sm00th/bitlbee-discord/issues/20 I think you forgot "-lwebsockets"

sm00th commented on 2016-01-13 12:03 (UTC)

diff --git a/PKGBUILD b/PKGBUILD index a3ec0d0..9db0c53 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -1,14 +1,14 @@ # Maintainer: Ranndom <Ranndom@rnndm.xyz> pkgname=bitlbee-discord-git -pkgver=45.b899973 +pkgver=74.ae894c5 pkgrel=1 pkgdesc="Bitlbee plugin for Discord" arch=('i686' 'x86_64') url="https://github.com/sm00th/bitlbee-discord" license=('GPL') depends=('bitlbee') -makedepends=('git' 'libwebsockets-git') +makedepends=('git' 'libwebsockets-git' 'autoconf' 'automake' 'libtool') source=("git+https://github.com/sm00th/bitlbee-discord") sha256sums=('SKIP') @@ -19,9 +19,13 @@ pkgver() { build() { cd "bitlbee-discord" + ./autogen.sh + # libwebsockets-git is screwed up pkg-config wise + PKG_CONFIG_PATH="/usr/lib/lib64/pkgconfig" LIBWEBSOCKETS_LIBS="-L/usr/lib/lib64" ./configure make } package() { - install -D -m644 $srcdir/bitlbee-discord/discord.so $pkgdir/usr/lib/bitlbee/discord.so + cd "bitlbee-discord" + make DESTDIR="$pkgdir" install }