Package Details: blackfire-cli 1.17.1-1

Git Clone URL: https://aur.archlinux.org/blackfire-cli.git (read-only)
Package Base: blackfire-cli
Description: Blackfire Profiler - Fire up your PHP Apps Performance
Upstream URL: https://blackfire.io
Licenses: custom
Submitter: bgaleotti
Maintainer: bgaleotti
Last Packager: bgaleotti
Votes: 7
Popularity: 0.000311
First Submitted: 2015-02-21 18:31
Last Updated: 2018-07-16 18:44

Dependencies (0)

Required by (0)

Sources (2)

Latest Comments

Talus commented on 2015-12-26 23:23

This package is outdated, and I flagged it as such. Here is the new PKGBUILD :

# Maintainer: Bruno Galeotti <bgaleotti AT gmail DOT com>
pkgname=blackfire-cli
pkgver=1.4.2
pkgrel=1
pkgdesc='Blackfire Profiler - Fire up your PHP Apps Performance'
arch=('i386' 'x86_64')
url='https://blackfire.io'
license='custom'
source_i386=("blackfire-cli-${pkgver}_i386::http://packages.blackfire.io/binaries/blackfire-agent/$pkgver/blackfire-cli-linux_386")
source_x86_64=("blackfire-cli-${pkgver}_x86_64::http://packages.blackfire.io/binaries/blackfire-agent/$pkgver/blackfire-cli-linux_amd64")
md5sums_i386=('2301cfa4aacea2010ca0d75d7c792a12')
md5sums_x86_64=('aed9311c7f15b3d0b40020343fbb3829')

package(){
install -Dm 755 blackfire-cli-${pkgver}_$CARCH "$pkgdir"/usr/bin/blackfire
}


Cheers.

mtorromeo commented on 2015-06-30 10:14

I fixed some issues with your package:
- variable quoting
- source versioning (so it doesn't conflict with older versions still in the source directory)
- no wildcard install (don't ever do this please)