Package Details: blather-git 20150830-1

Git Clone URL: https://aur.archlinux.org/blather-git.git (read-only)
Package Base: blather-git
Description: Python application for speech recognition using pocketsphinx and gstreamer. - latest git revision
Upstream URL: https://gitlab.com/jezra/blather
Licenses: GPL3
Provides: blather
Submitter: timttmy
Maintainer: timttmy
Last Packager: timttmy
Votes: 4
Popularity: 0.000989
First Submitted: 2013-06-07 20:34
Last Updated: 2015-08-30 07:52

Dependencies (7)

Required by (0)

Sources (1)

  • blather.desktop

Latest Comments

surfhai commented on 2015-11-02 19:34

jezra tested blather with the latest sources of pocketsphinx and it won't work. To update blather that it will work with pocketsphinx-prealpha5 requires updating to the following packages:
gstreamer1.0
GTK3
Python3

And the QT based UI will no longer function. To solve this we have to install pocketsphinx-0.8 and sphinxbase 0.8

surfhai commented on 2015-10-25 11:37

It didn't work. I installed gstreamer0.10-plugins and python2-yaml but after adding a command like
terminal : urxvt
and run
$ Blather
I get this message:
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
terminal : urxvt

terminal urxvt
no element "vader"
You may need to install gstreamer0.10-pocketsphinx

I also checked the presence of /usr/lib/gstreamer-1.0/libgstpocketsphinx.so

timttmy commented on 2015-08-30 07:56

Thanks for the notification anxiety. Package fixed. :)

anxiety commented on 2015-08-30 05:18

blather-git has been moved to gitlab.
I locally changed the package build to get it to install:
-_gitroot="git://gitorious.org/blather/blather.git"
+_gitroot="https://gitlab.com/jezra/blather.git"

commontime commented on 2015-05-30 19:51

I just installed and was getting error:
no element "autoaudiosrc"
You may need to install gstreamer0.10-pocketsphinx

After installing gstreamer0.10-plugins it appears to be working

timttmy commented on 2014-11-10 21:48

Also jezra informs me that he has updated the blather code today to stop running after the "You may need to install gstreamer0.10-pocketsphinx" error message.
Hope this helps :)

timttmy commented on 2014-11-10 21:34

I had a brief conversation with jezra (blather dev) last night. Most likely your missing gstreamer0.10-pocketsphinx.
Could you check if you have libgstpocketsphinx.so in /usr/lib/gstreamer-0.10

cstandard commented on 2014-11-08 00:15

Hello. I installed updated arch yesterday and today installed all files related to Blather and its dependencies. The installation went great and I was even able to generate the lm and dic files, which I placed in the proper directory. My problem is that when I attempt to run the program I get the following error:

File "/usr/share/blather/Recognizer.py", line 36, in __init__
asr=self.pipeline.get_by_name('asr')
AttributeError: 'Recognizer' object has no attribute 'pipeline'

I do not know how to resolve this problem. Is there any possibility that you could help trouble-shoot this?

timttmy commented on 2014-11-02 08:52

@flu Done :)

flu commented on 2014-10-31 09:03

Just to avoid confusion please modify:
see /usr/share/blather/README to configure Blather for first use
enable Blather in your DE Aplication Autostart config to launch on login
to:
see /usr/share/blather/README.md to configure Blather for first use
enable Blather in your DE Aplication Autostart config to launch on login

All comments