Package Details: bleachbit-cli 2.2-2

Git Clone URL: https://aur.archlinux.org/bleachbit-cli.git (read-only)
Package Base: bleachbit-cli
Description: Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.
Upstream URL: https://www.bleachbit.org/
Licenses: GPL3
Provides: bleachbit=2.2
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 16
Popularity: 0.132612
First Submitted: 2011-11-18 19:35
Last Updated: 2019-05-11 13:02

Dependencies (2)

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

msx commented on 2013-01-31 03:54

Hi,
I just stumbled across an issue trying to run Bleachbit with pkexec since the upstream doesn't provide the needed .policy file.
Until they finally add it -they proven to be very diligent on fixing bugs and accepting patches- may be it could be a good idea to add it to it's PKGBUILD.

If you choose to add it, maybe you would like to name it something like 'org.archlinux.pkexec.bleachbit.policy' (I chosen to follow the naming scheme other AUR packagers used).

The file must be installed in /usr/share/polkit-1/actions and it will enable pkexec to launch Bleachbit effectively rendering sudo/gksu/kdesu obsolete.

Grab it here: http://pastebin.com/Nj36aWDw

graysky commented on 2012-09-13 19:35

@koz -

1) Should be but I have not tested.
2a) That problem is on your end. I had no problems myself.

$ sha256sum bleachbit-0.9.3.tar.bz2
76bb62166d05ebf209dff4811342ba5a7acafc534597709152b314aa06936c47 bleachbit-0.9.3.tar.bz2

2b) Try building with makepkg... I never liked AUR helpers due to quirks with certain PKGBUILDs.

kozaki commented on 2012-09-13 10:17

Thanks to graysky for maintaining this other usefull cli-tool.

1) is latjay's bleachbit-bonus compatible with this one?

2) Got an error today - installing bleachbit-cli:

a - validating bealchbit source file fails (three time). sha256sum gives me different values each time !? eg:
413ada88f2110b1bcc32c29bba33c72a93d87f6f3dc56df0dc1bc456302659ad bleachbit-0.9.3.tar.bz2
f7a636ef8fde927fb4889ec6d276d3b77e77b06cce42a2f47203734f23fdff24 bleachbit-0.9.3.tar.bz2

b - probably linked to (a) if i edit the PKGBUILD the build fails as the tarball is not uncompressed:
/tmp/yaourt-tmp-archie/aur-bleachbit-cli/./PKGBUILD: ligne 24 : cd: /tmp/yaourt-tmp-archie/aur-bleachbit-cli/src/bleachbit-0.9.3: Aucun fichier ou dossier de ce type
[me@pc aur-bleachbit-cli]$ ls src/
bleachbit-0.9.3.tar.bz2

graysky commented on 2012-09-02 15:24

Fek... I stand corrected as does the PKGBUILD. Thank you for your persistence :)

luolimao commented on 2012-09-02 14:08

In fact, latjay maintains bleachbit-bonus (which is probably why they posted the recommendation in the first place).

luolimao commented on 2012-09-02 14:06

Actually, bleachbit-bonus [1] requires bleachbit.

[1] https://aur.archlinux.org/packages.php?ID=61195

graysky commented on 2012-09-02 14:03

@luoimao - Right you are. The more I think about it, the provides array is pretty useless as no other packages require bleachbit... at least now.

luolimao commented on 2012-09-02 05:31

the provides array should be (as latjay noted)
provides=("bleachbit=${pkgver}")
not
provides=("bleachbit-${pkgver}")

graysky commented on 2012-08-22 20:33

Bump to 0.9.3-2

Changelog: Added provides array per user suggestion.
Commit:

graysky commented on 2012-05-07 23:32

Bump to v0.9.2-2

Changelog: Took Meow's suggestion to force cli mode with this package and removed unnecessary .desktop and .png files.
PKGCommit: http://pkgbuild.com/git/aur-mirror.git/commit/bleachbit-cli?id=718a9d9b8c42be2ee67c2d483768c1ec7902f291