Package Details: blink-darcs 20160602-2

Git Clone URL: (read-only)
Package Base: blink-darcs
Description: A state of the art, easy to use SIP client
Upstream URL:
Keywords: SIP VOIP
Licenses: GPL
Submitter: promike
Maintainer: None
Last Packager: promike
Votes: 1
Popularity: 0.067701
First Submitted: 2016-06-01 14:07
Last Updated: 2016-06-02 12:17

Required by (0)

Sources (0)

Latest Comments

promike commented on 2016-10-06 21:47

I hereby submit my resignation.
This package is NOT going to be or shouldn't be maintained any longer.

!!Under no circumstances should you install it on your computer!!

The creators of Blink claimed we had better not build blink-darcs straight from an arbitrary point in time by just pulling it from the repository.
Even though they try to keep it as stable as just possible, there is no guarantee it will work. It may depend on newer versions of other dependencies, which cannot be satisfied at the very moment.
You can still build it at your own risk.

Nevertheless, I suggest building this version of Blink :

darkbasic commented on 2016-08-31 10:16

The other version of blink worked, thanks.

promike commented on 2016-08-10 17:44


Fortunately, I haven't come across any problems with this version of the Blink.

There's no package like 'googleapiclient' and you could install it via pip.
[sudo pacman -S python2-pip; sudo pip2 install google-api-python-client]

!! However I don't advise you to touch these things manually. !!

Probably it would do the trick, but there's also a github version of Blink, which is provided by our fellow; ogarcia. Try to install his PKGBUILD first then try to irrevocably mess up your system :D

darkbasic commented on 2016-08-10 15:43

$ blink
:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'. Please install it from <> and make sure all of its dependencies are satisfied. Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification. Many valid certificate/hostname mappings may be rejected.
Traceback (most recent call last):
File "/usr/bin/blink", line 33, in <module>
from blink import Blink
File "/usr/lib/python2.7/site-packages/blink/", line 41, in <module>
from blink.chatwindow import ChatWindow
File "/usr/lib/python2.7/site-packages/blink/", line 37, in <module>
from blink.contacts import URIUtils
File "/usr/lib/python2.7/site-packages/blink/", line 27, in <module>
from googleapiclient.discovery import build
ImportError: No module named googleapiclient.discovery

promike commented on 2016-06-02 10:18

Good point!
Thank you for your help. I updated the PKGBUILD.

glitsj16 commented on 2016-06-01 22:31

Hi, thanks for offering this package. The PKGBUILD can drop some dependencies though.
python2-sipsimple depends on python2-application (which installs python2), python-otr, python2-eventlib and python2-msrplib (which takes care of installing python2-gnutls and twisted).
So to summarize: depends=('cython2' 'libvncserver' 'python2-cjson' 'python2-gmpy2' 'python2-pyqt' 'python2-sipsimple')