Package Details: blink 5.6.0-1

Git Clone URL: https://aur.archlinux.org/blink.git (read-only, click to copy)
Package Base: blink
Description: Fully featured, easy to use SIP client with a Qt based UI
Upstream URL: https://icanblink.com
Keywords: SIP VoIP
Licenses: GPL-3+
Submitter: ogarcia
Maintainer: josemslopes
Last Packager: josemslopes
Votes: 13
Popularity: 0.000475
First Submitted: 2016-06-18 13:13 (UTC)
Last Updated: 2023-08-03 13:02 (UTC)

Latest Comments

1 2 3 4 5 6 .. 12 Next › Last »

josemslopes commented on 2023-08-03 13:46 (UTC)

@bsdice Thanks for your feedback. I added the cython0 package to makedepends.

bsdice commented on 2023-08-01 11:41 (UTC)

As is good custom in python-land (sarcasm), the upgrade to "cython 3" broke compilation. But there is a cython0 package which works. Maintainer might want to add it to makedepends. Since this breakage is never-ending, Nix and Rust obviously with superior concepts.

josemslopes commented on 2023-04-01 13:13 (UTC)

@bsdice Thanks for your feedback. Since there is no tag for 5.5.1 on the upstream git repo, we can still don't have the patch here. But you can use blink-git package to get the last commits from the upstream git repo.

josemslopes commented on 2023-04-01 12:49 (UTC)

@mwberry Thanks for your feedback. I follow your option 1.

josemslopes commented on 2023-04-01 12:41 (UTC)

@loxothrone Thanks for your feedback. I updated the package python-sipsimple. Reinstall it, so that it fixes the issue.

loxothrone commented on 2023-03-15 18:12 (UTC)

ImportError: libvpx.so.7: cannot open shared object file: No such file or directory

i install require version from AUR but still doesn't figure out how to point Blink to it

mwberry commented on 2022-12-06 07:11 (UTC)

blink depends on python-pyqt5-webkit and python-pyqt5. Although python-pyqt5-webkit provides python-pyqt5 and can satisfy both dependencies, the package pyqt5 from Extra also provides python-pyqt5. python-pyqt5-webkit conflicts with python-pyqt5.

Option 1: remove python-pyqt5 in favor of python-pyqt5-webkit. The downside of this is that python-pyqt5 is an official repo package, so it should be preferred.

Option 2: Find a packaging of python-pyqt5-webkit that only contains webkit / is not a superset of python-pyqt5 so that both can be kept.

bsdice commented on 2022-12-02 22:26 (UTC)

Just another comment, in my private build I added from unreleased 5.5.1 this patch:

https://github.com/AGProjects/blink-qt/commit/c219e00a63cf972f2b7c05cd29451c61107cc8de.patch

Recently had to replace a faulty 24" 1920x1200 display and went with a 32" 4K display. Without the patch the spacing of dialog items on my i3 desktop with Noto Sans 12 font was 'crushed'. With the patch there are some small items left like contact list and icons not scaling in high quality, but UI is perfectly usable.

To repeat my comment from years ago for anyone looking, this is imho still the best SIP telephony client on Linux.

josemslopes commented on 2022-12-02 14:58 (UTC)

@bsdice Thanks for your feedback. I updated the version and the dependencies

bsdice commented on 2022-11-24 23:30 (UTC)

I just built the package but depends=... is missing 'python-pyqt5-webkit'. Please add it thanks.