Package Details: blockify 3.6.3-3

Git Clone URL: https://aur.archlinux.org/blockify.git (read-only)
Package Base: blockify
Description: Mutes Spotify advertisements.
Upstream URL: https://github.com/mikar/blockify
Licenses: MIT
Conflicts: blockify-git
Submitter: serialoverflow
Maintainer: serialoverflow
Last Packager: serialoverflow
Votes: 122
Popularity: 1.957514
First Submitted: 2013-12-19 22:18
Last Updated: 2016-11-29 23:36

Latest Comments

cjmick commented on 2017-10-18 05:31

Ok I installed the optional dependencies sudo pacman -S git python-pip gst-python pulseaudio alsa-utils pygtk python-dbus python-gobject python-docopt wmctrl

and I was able to get Blockify muting the spotify ads. Now when I pause spotify to view a youtube video, I now get no audio. The same with Facebook.

cjmick commented on 2017-10-18 02:58

Just installed spotify and blockify, noticed blockify doesn't stop/mute the ads. Is there a fix for this?

jtojnar commented on 2017-05-27 15:49

@polyzen the readme is outdated. pygtk only provides GTK 2 support which is not used by blockify.

polyzen commented on 2017-05-06 07:14

jtoljnar, python-gobject is a dep of gst-python, and the readme mentions pygtk as a dependency.

polyzen commented on 2017-05-06 06:59

Interlude player broken for anyone else?

jtojnar commented on 2017-04-30 22:08

This actually depends on python-gobject, not pygtk.

NicholasAsimov commented on 2017-02-07 11:49

Edit: reinstalling helped. Maybe python 3.6 update caused some modules to not transfer or something?

Getting this error lately. Can't remember what started to cause this.

> blockify
Traceback (most recent call last):
File "/usr/bin/blockify", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3030, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3014, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3043, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 654, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'blockify==3.6.3' distribution was not found and is required by the application

polyzen commented on 2017-01-30 23:48

Don't have that installed, here. ~~Can't recall having recent issues with Blockfiy.~~
Edit: Looks like I recalled incorrectly; have to do a similar workaround as the one below with Blockify.

Spotify-Adkiller, at least, requires toggling play/pause during/after ads (after the 2nd ad or so ad) to work properly, here.

rndbits commented on 2017-01-30 12:28

I had commercials not being muted as well. I had to install lib32-gstreamer for blockify to work again.
I haven't really tested if that was the problem though.

luiscuadrado123 commented on 2017-01-26 18:46

not working?

i am listening adds since yesterday with the last updates of spotify and blockify

All comments