Package Details: blueprint-compiler-git r80.d0cf13b-1

Git Clone URL: https://aur.archlinux.org/blueprint-compiler-git.git (read-only, click to copy)
Package Base: blueprint-compiler-git
Description: A markup language for GTK user interfaces
Upstream URL: https://jwestman.pages.gitlab.gnome.org/blueprint-compiler
Licenses: LGPL3
Conflicts: blueprint-compiler
Provides: blueprint-compiler
Submitter: gabmus
Maintainer: gabmus
Last Packager: gabmus
Votes: 5
Popularity: 0.000068
First Submitted: 2021-12-03 08:39 (UTC)
Last Updated: 2021-12-03 19:15 (UTC)

Required by (126)

Sources (1)

Latest Comments

xiota commented on 2023-04-08 23:04 (UTC)

======================================================================
ERROR: blueprintcompiler.language (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: blueprintcompiler.language
Traceback (most recent call last):
  File "/usr/lib/python3.10/unittest/loader.py", line 470, in _find_test_path
    package = self._get_module_from_name(name)
  File "/usr/lib/python3.10/unittest/loader.py", line 377, in _get_module_from_name
    __import__(name)
  File "/home/main-builder/pkgwork/src/blueprint-compiler/blueprintcompiler/language/__init__.py", line 1, in <module>
    from .gtk_list_item_factory import ListItemFactory
  File "/home/main-builder/pkgwork/src/blueprint-compiler/blueprintcompiler/language/gtk_list_item_factory.py", line 1, in <module>
    from .gobject_object import ObjectContent, validate_parent_type
  File "/home/main-builder/pkgwork/src/blueprint-compiler/blueprintcompiler/language/gobject_object.py", line 24, in <module>
    from .common import *
  File "/home/main-builder/pkgwork/src/blueprint-compiler/blueprintcompiler/language/common.py", line 21, in <module>
    from .. import gir
  File "/home/main-builder/pkgwork/src/blueprint-compiler/blueprintcompiler/gir.py", line 24, in <module>
    import gi  # type: ignore
ModuleNotFoundError: No module named 'gi'

The following resolves the above error:

depends=('python')
makedepends=('git' 'meson')
checkdepends=('gtk4' 'python-gobject')

But check still fails:

1/1 tests FAIL            5.21s   killed by signal 11 SIGSEGV
>>> MALLOC_PERTURB_=35 /usr/bin/python3 -m unittest
――――――――――――――――――――――――――――――――――――― ✀  ―――――――――――――――――――――――――――――――――――――
stderr:
FF
――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

mazharhussain commented on 2022-11-03 18:03 (UTC) (edited on 2022-11-03 18:04 (UTC) by mazharhussain)

This was an issue in the upstream project, not in the PKGBUILD and has already been fixed for a long time now.

igor-dyatlov commented on 2022-11-03 17:52 (UTC)

@jonas-w: try this https://pastebin.com/mARPdWpk

jonas-w commented on 2022-06-12 23:41 (UTC)

Can't get this package to install. Only can install it through manually compiling it with the instructions on the gitlab page.

The only error (when installing through AUR) is that it can't find the blueprintcompiler python module

mazharhussain commented on 2022-02-26 19:55 (UTC) (edited on 2022-02-26 20:09 (UTC) by mazharhussain)

blueprint-compiler requires gobject-introspection to work. So, it should be moved from makedepends to depends array.

And python dependency should be replaced by python-gobject since blueprint-compiler depends on it to work.

depends=('python-gobject' 'gobject-introspection' 'gtk4')
makedepends=('git' 'meson')

yochananmarqos commented on 2021-12-03 16:28 (UTC)

There are no tags available, please include the revision as well:

pkgver() {
  cd "$srcdir/${pkgname%-git}"
  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
r80.d0cf13b