Package Details: boatswain-git 0.1.0.r171.702ecce-1

Git Clone URL: https://aur.archlinux.org/boatswain-git.git (read-only, click to copy)
Package Base: boatswain-git
Description: Control Elgato Stream Deck devices
Upstream URL: https://gitlab.gnome.org/World/boatswain
Licenses: GPL3
Conflicts: boatswain
Provides: boatswain
Submitter: frostwork
Maintainer: rafaelff
Last Packager: rafaelff
Votes: 1
Popularity: 0.156370
First Submitted: 2022-03-18 17:08 (UTC)
Last Updated: 2022-04-29 17:09 (UTC)

Latest Comments

frostwork commented on 2022-04-29 14:30 (UTC)

I orphaned the PKGBUILD shortly after release because upstream only supports flathub: https://gitlab.gnome.org/World/boatswain/-/issues/23#note_1411273 Feel free to take over. I do no longer care for the project.

rafaelff commented on 2022-04-29 14:27 (UTC) (edited on 2022-04-29 14:28 (UTC) by rafaelff)

namespace changed to https://gitlab.gnome.org/World/boatswain, please change $url and $source accordingly.

rafaelff commented on 2022-04-13 18:53 (UTC) (edited on 2022-04-13 18:53 (UTC) by rafaelff)

Weird enough, src/meson.build requires libpeas-1.0 >= 1.17, however Arch provides 1.32.0

intothemild commented on 2022-03-27 19:28 (UTC)

Resolved the libpeas-1.0 issue by installing libpeas-git from the AUR

rafaelff commented on 2022-03-21 10:07 (UTC)

URL's namespace changed to /World/

lxalln commented on 2022-03-21 09:36 (UTC) (edited on 2022-03-21 09:37 (UTC) by lxalln)

I'm getting the following error when trying to build:

Run-time dependency libpeas-1.0 found: NO (tried pkgconfig and cmake)

src/meson.build:24:0: ERROR: Dependency "libpeas-1.0" not found, tried pkgconfig and cmake

frostwork commented on 2022-03-18 17:10 (UTC)

I haven't created many PKGBUILDS before, so you're invited to review it or even (co-)maintain the PKGBUILD. I might not even find the time to maintain it for a longer time, but wanted to contribute something to this nice tool.