Package Details: boblight r479-2

Git Clone URL: https://aur.archlinux.org/boblight.git (read-only)
Package Base: boblight
Description: Collection of tools for driving lights connected to an external controller
Upstream URL: http://code.google.com/p/boblight/
Licenses: GPL2
Submitter: CReimer
Maintainer: None
Last Packager: CReimer
Votes: 1
Popularity: 0.000781
First Submitted: 2015-02-25 19:30
Last Updated: 2016-02-26 15:12

Latest Comments

artodeto commented on 2018-03-07 21:48

Same here @ dominicm. Could you please update the source url from http://code.google.com/p/boblight/ to something available on github or similar?

You can also use the link from jake: https://storage.googleapis.com/google-code-archive-source/v2/code.google.com/boblight/source-archive.zip

You have to add the following steps to your PKGBUILD:

pkgver() {
  cd "$srcdir"
  svn upgrade
  cd "trunk"
  local ver="$(svnversion)"
  printf "r%s" "${ver//[[:alpha:]]}"
}

build() {
  cd "$srcdir/trunk"

  ./configure --prefix=/usr \
              --disable-static \
              --with-ffmpeg
  make
}

dominicm commented on 2016-11-12 18:09

-> Creating working copy of trunk svn repo...
==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r
The build failed.

Jake commented on 2016-05-16 10:50

The svn checkout does not work anymore. Download it instead from the archive: "https://storage.googleapis.com/google-code-archive-source/v2/code.google.com/boblight/source-archive.zip" (also only available throughout the rest of 2016)
A alternative would be a GitHub, there are many exports, but without any actual development...

CReimer commented on 2015-04-04 21:41

I changed it. I tried to save some disk space with this setting.

It's now everything set to default. Therefore portaudio support is now available, too.

Ttz_ztT commented on 2015-04-04 21:09

Nice.
But why --without-X11?
boblight-X11 rules :)