Package Details: bomi 0.9.11-5

Git Clone URL: https://aur.archlinux.org/bomi.git (read-only)
Package Base: bomi
Description: Powerful and easy-to-use GUI multimedia player based on mpv
Upstream URL: http://bomi-player.github.io
Licenses: GPL2
Conflicts: bomi-fresh, bomi-git
Provides: cmplayer
Submitter: xylosper
Maintainer: itsme
Last Packager: itsme
Votes: 108
Popularity: 0.966476
First Submitted: 2015-01-18 00:18
Last Updated: 2017-12-15 09:49

Dependencies (32)

Required by (0)

Sources (3)

Latest Comments

cb474 commented on 2018-06-07 20:57

@m110s Thanks!

I also noticed that there is a git versioin of bomi in AUR, that looks like it's perhaps being maintained more actively: https://aur.archlinux.org/packages/bomi-git/ I found it installed without any errors on my system. Any reason not to prefer that package?

m110s commented on 2018-06-06 10:28

@cb474 I'll explain my primitive way. :) Create working directory and type: yaourt -G bomi . Enter bomi directory and edit ffmpeg2.8.patch. Replace first 9 lines with kragol solution. Then edit PKGBUILD and replace md5sum in line 29 with a9a749464b0844a4de6bbc49421e3839 . Save PKGBUILD, type: makepkg and install with sudo pacman -U bomi-0.9.11-5-x86_64.pkg.tar .

cb474 commented on 2018-06-05 12:27

@m110s @kragol Would you mind explaining how to modify and use the modified patch file, so that the pkgbuild finds it?

m110s commented on 2018-06-04 11:53

@kragol Your modified patch works for me. Thanks a lot mate!

kragol commented on 2018-05-30 14:03

There seems to be an issue with the ffmpeg2.8 patch.

With the new version of x265, I could not get bomi to update without error. I then removed bomi and updated x265 and ffmpeg2.8. However after that, trying to reinstall bomi would fail at build time, complaining that it could not find avfiltergraph.h ( video/ffmpegfilters.hpp:9:10: fatal error: libavfilter/avfiltergraph.h: No such file or directory ). avfiltergraph.h is actually provided by ffmpeg2.8 but was not made accessible in the build script.

In order to fix the issue, I modified the ffmpeg2.8.patch file, adding the ffmpeg2.8 location to the INCLUDEPATH. The first block of the modified patch looks like

diff -urN src.ori/bomi/bomi.pro src/bomi/bomi.pro
--- src.ori/bomi/bomi.pro   2016-04-21 18:38:40.301930585 +0900
+++ src/bomi/bomi.pro   2016-04-21 18:39:19.158598613 +0900
@@ -9,7 +9,7 @@
 DESTDIR = $${PWD}/../../build
 LIB_DIR = $${DESTDIR}/lib
-INCLUDEPATH += ../mpv ../mpv/build kiss_fft
-LIBS += -L$${LIB_DIR} -lbz2 -lz
+INCLUDEPATH += ../mpv ../mpv/build kiss_fft /usr/include/ffmpeg2.8
+LIBS += -L$${LIB_DIR} -L/usr/lib/ffmpeg2.8 -lbz2 -lz

If somebody can confirm I did not do something stupid, it may be worth updating the patch file.

m110s commented on 2018-05-29 16:17

Again ffmpeg2.8 issue: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64'

Kakashi-sensei commented on 2018-03-26 14:36

I deleted ~/.config/xylosper/ and it fixed it. I still don't know what the issue is, but it can't be fixed since xylosper is no longer working on the program.

Kakashi-sensei commented on 2018-03-26 14:29

I want to know why my player suddenly started playing at 32-33 fps, even after re-compiling.

I will try again, but I think it will be the same result.

itsme commented on 2018-03-25 08:32

Just recompiled this package without any problems. @Kakashi-sensei, I do not have any problems. What exactly you want?

Kakashi-sensei commented on 2018-03-24 16:10

Output framerate is too high.

All comments