Package Details: bonita-bpm-community-bin 7.3.3-1

Git Clone URL: https://aur.archlinux.org/bonita-bpm-community-bin.git (read-only)
Package Base: bonita-bpm-community-bin
Description: Bonita BPM Studio with embedded Engine + Portal
Upstream URL: http://www.bonitasoft.com/how-we-do-it#how-we-do-it_bonita-bpm
Licenses: GPL2
Provides: bonita-bpm-community
Submitter: dumblob
Maintainer: dumblob
Last Packager: dumblob
Votes: 2
Popularity: 0.000026
First Submitted: 2015-02-24 16:11
Last Updated: 2016-11-29 19:29

Dependencies (9)

Required by (0)

Sources (2)

Latest Comments

dumblob commented on 2018-01-07 12:31

Hello everybody, upstream renamed the "Bonita BPM Community" to "Bonita Studio Community" and thus I created a new package (with a hack/workaround for the long-standing issue preventing me to update this package - https://github.com/bonitasoft/bonita-studio/issues/397 ):

https://aur.archlinux.org/packages/bonita-studio-community-bin/

This package "bonita-bpm-community-bin" will not be updated any more (I'll manage its removal at some point). Feel free to vote for the new package linked above ;)

dumblob commented on 2015-10-03 19:10

Thank yoou @cleocir . I'm still unable to reproduce the error on my machine.

Please try to build the package using a slightly modified version of the PKGBUILD - https://github.com/dumblob/tmp/blob/master/bonita-bpm-community-bin/PKGBUILD and post here your results.

If it fails, please post somewhere (e.g. to pastebin) the result of "find pkg src" ran from the directory with failed makepkg and post here a link.

cleocir commented on 2015-09-25 11:22

@dumblob i have tried with manual command "makepkg -s" and the same errors stay.

:/

Your suggested test result:

[cleocir@nb-cleocir tmp]$ cd /tmp
[cleocir@nb-cleocir tmp]$ mkdir -p 'test 00/dir 00/'
[cleocir@nb-cleocir tmp]$ touch 'test 00/dir 00/abc.desktop'
[cleocir@nb-cleocir tmp]$ echo "test 00/dir 00/"*.desktop
test 00/dir 00/abc.desktop
[cleocir@nb-cleocir tmp]$


dumblob commented on 2015-09-24 21:19

@cleocir, maybe I wasn't clear enough, but please run *makepkg -s* manually. It seems, that the shell which yaourt executes somehow doesn't support expansion of "some/path/"*.extension . You can try if your interactive shell (not the one yaourt uses) does support such expansion e.g. by:

cd /tmp
mkdir -p 'test 00/dir 00/'
touch 'test 00/dir 00/abc.desktop'
echo "test 00/dir 00/"*.desktop

cleocir commented on 2015-09-24 16:18

@dumblob the same error stay:

==> Starting package()...
ls: cannot access *.desktop: No such file or directory
/tmp/yaourt-tmp-raph/aur-bonita-bpm-community-bin/./PKGBUILD: line 70: usr/bin/: Is a directory
==> ERROR: A failure occurred in package().

Maybe the package is need a ".desktop" file?

dumblob commented on 2015-09-22 11:57

@cleocir I updated the package to a new version 7.1.0 and successfully tested it. If you still have any issues, please try to build the package manually using *makepkg -s* as I asked below (2015-05-05 13:34) and post your results here in case they're defective.

cleocir commented on 2015-09-21 16:33

Same error commented by @rdoursenaud

Please help us!

dumblob commented on 2015-05-05 13:34

@rdoursenaud, I've looked into it (and tried both x86 and x86_64 variants), but didn't find anything suspicious. Everything runs fine on my system.

Could you please just download tarball from this page, unpack it somewhere and run "makepkg -s" in the unpacked directory with PKGBUILD to see if this works? I don't know what everything yaourt does, but e.g. with packer (https://aur.archlinux.org/packages/packer-git/) it works without any issues for me.

rdoursenaud commented on 2015-05-05 12:37

Does not work for me:
==> Starting package()...
ls: cannot access *.desktop: No such file or directory
/tmp/yaourt-tmp-raph/aur-bonita-bpm-community-bin/./PKGBUILD: line 70: usr/bin/: Is a directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build bonita-bpm-community-bin.