Package Details: bookwyrm-git v0.5.0.r0.g92cd41b-1

Git Clone URL: https://aur.archlinux.org/bookwyrm-git.git (read-only)
Package Base: bookwyrm-git
Description: traverse various sources, find ebooks/textbooks/papers, and download them
Upstream URL: https://github.com/Tmplt/bookwyrm
Licenses: MIT
Conflicts: bookwyrm
Provides: bookwyrm
Submitter: tmplt
Maintainer: tmplt
Last Packager: tmplt
Votes: 0
Popularity: 0.000000
First Submitted: 2018-05-11 22:19
Last Updated: 2018-05-11 22:19

Dependencies (4)

Required by (0)

Sources (1)

Pinned Comments

tmplt commented on 2018-05-11 22:29

The following non-standard python libraries must be installed for the Library Genesis plugin to work: bs4, furl, requests and isbnlib.

I'll review the dependencies and add if anything's missing from the AUR later.

Latest Comments

tmplt commented on 2018-05-27 21:14

Bookwyrm now installs everything into correct directories.

tmplt commented on 2018-05-11 22:29

The following non-standard python libraries must be installed for the Library Genesis plugin to work: bs4, furl, requests and isbnlib.

I'll review the dependencies and add if anything's missing from the AUR later.

tmplt commented on 2018-05-11 22:24

namcap(1) says the following:

bookwyrm-git W: File (usr/etc/) exists in a non-standard directory.
bookwyrm-git W: File (usr/etc/bookwyrm/) exists in a non-standard directory.
bookwyrm-git W: File (usr/etc/bookwyrm/plugins/) exists in a non-standard directory.
bookwyrm-git W: File (usr/etc/bookwyrm/plugins/libgen.py) exists in a non-standard directory.
bookwyrm-git E: Missing custom license directory (usr/share/licenses/bookwyrm-git)

and I'm aware of it; these install paths shall be fixed.