Package Details: boost174 1.74.0-6

Git Clone URL: https://aur.archlinux.org/boost174.git (read-only, click to copy)
Package Base: boost174
Description: Free peer-reviewed portable C++ source libraries (version 1.74) (development headers)
Upstream URL: https://www.boost.org/
Licenses: BSL-1.0
Submitter: carsme
Maintainer: carsme
Last Packager: carsme
Votes: 1
Popularity: 0.000290
First Submitted: 2023-03-12 19:04 (UTC)
Last Updated: 2024-01-17 16:13 (UTC)

Latest Comments

1 2 Next › Last »

simona commented on 2023-09-02 19:37 (UTC)

thx... it is sufficient reinstall pkg. thx for hint.

simona commented on 2023-09-02 19:25 (UTC)

Thx I will try

carsme commented on 2023-09-02 19:24 (UTC)

@simona Can you try and rebuild that package and see if that fixes your issue? Rebuilding it will make it link to the new boost version and hopefully the package is compatible with that.

simona commented on 2023-09-02 19:19 (UTC)

I have this one:
https://aur.archlinux.org/packages/wsjtz

carsme commented on 2023-09-02 18:56 (UTC)

@simona I wouldn't mind adding a 1.81 package if there is use for it. Do you have any examples of packages that require boost version 1.81 specifically?

simona commented on 2023-09-02 18:44 (UTC)

a new boost181 and boost-libs181 like this?

carsme commented on 2023-07-25 20:34 (UTC)

Hey @FabioLolix, thank you for the feedback.

I think I have addressed it all in the latest package update, feel free to have a look.

FabioLolix commented on 2023-07-04 20:40 (UTC)

Hello again, for the records I see you have removed the conflict with Arch boost (https://aur.archlinux.org/cgit/aur.git/commit/?h=boost174&id=2769a59fa571119f13756dbc465fabf9321ed8ca)

For license you can write license=(Boost) since this is a common license which is in the licenses packages, seems this need to be corrected in Arch package too

About the depends=("boost-libs=$pkgver") in package_boost174(), while it works for the builded package it looks weird here on AURweb, where you see in Dependencies (8) the full list of boost-libs providers boost-libs (boost171, boost-libs-git, boost-libs_v180, boost174-libs)

About provides in package_boost174-libs() please remove them all as this isn't a drop-in for boost-libs and confuses the pacman db, I have the packages builded and added to my local repository for the example below

  • This is without boost174 installed, trying to remove will break the boost-libs requirement
$ sudo pacman -R boost boost-libs
[sudo] password for fabio: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing boost-libs breaks dependency 'boost-libs' required by imagescan
:: removing boost-libs breaks dependency 'boost-libs' required by innoextract
:: removing boost-libs breaks dependency 'boost-libs' required by lgogdownloader
:: removing boost-libs breaks dependency 'boost-libs' required by libixion
:: removing boost-libs breaks dependency 'boost-libs' required by libtorrent-rasterbar
:: removing boost-libs breaks dependency 'boost-libs' required by mkvtoolnix-cli
  • Installing boost174 boost174-libs
$ sudo pacman -S boost174 boost174-libs
resolving dependencies...
looking for conflicting packages...

Packages (2) boost174-1.74.0-3  boost174-libs-1.74.0-3

Total Installed Size:  169.59 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                                                                                                                           [##############################################################################################] 100%
(2/2) checking package integrity                                                                                                                         [##############################################################################################] 100%
(2/2) loading package files                                                                                                                              [##############################################################################################] 100%
(2/2) checking for file conflicts                                                                                                                        [##############################################################################################] 100%
(2/2) checking available disk space                                                                                                                      [##############################################################################################] 100%
:: Processing package changes...
(1/2) installing boost174-libs                                                                                                                           [##############################################################################################] 100%
Optional dependencies for boost174-libs
    openmpi: for mpi support [installed]
(2/2) installing boost174                                                                                                                                [##############################################################################################] 100%
Optional dependencies for boost174
    python: for python bindings [installed]
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
  • Now is possible to remove boost-libs without apparent breakage
$ sudo pacman -R boost boost-libs
checking dependencies...
:: botan optionally requires boost-libs: for the botan executable
:: imath optionally requires boost-libs: python bindings

Packages (2) boost-1.81.0-7  boost-libs-1.81.0-7

Total Removed Size:  182.78 MiB

:: Do you want to remove these packages? [Y/n] y
:: Processing package changes...
(1/2) removing boost                                                                                                                                     [##############################################################################################] 100%
(2/2) removing boost-libs                                                                                                                                [##############################################################################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
  • Programs that depends on boost-libs no longer works
$ lgogdownloader
lgogdownloader: error while loading shared libraries: libboost_filesystem.so.1.81.0: cannot open shared object file: No such file or directory

MarsSeed commented on 2023-06-14 22:38 (UTC)

Thanks for the fixes.

MarsSeed commented on 2023-06-12 15:55 (UTC)

This is not a proper generic boost v1.74 package, as it hardcodes Python 3.9.

Please rebuild with current Arch repo python, or rename the package to something like boost174-python39.