Package Details: borgmatic 1.0.3-1

Git Clone URL: https://aur.archlinux.org/borgmatic.git (read-only)
Package Base: borgmatic
Description: A simple Python wrapper script for the borg (and attic) backup software.
Upstream URL: http://torsion.org/borgmatic/
Licenses: GPL3
Provides: borgmatic
Submitter: nylocx
Maintainer: nylocx
Last Packager: nylocx
Votes: 11
Popularity: 2.458366
First Submitted: 2016-02-18 13:48
Last Updated: 2017-01-13 13:36

Latest Comments

nylocx commented on 2017-09-23 07:59

Thanks a lot for your work, if you would like to maintain the package, either as co-maintainer or main maintainer, I would be happy to give you permission to do so.
I also received a mail from Lektron suggesting that you maintain this package if you want and I agree with him.
Just let me know what you decide.

stef204 commented on 2017-09-06 16:59

@nylock
thanks for feedback. Basically, the "hack" was to manually install the proper python-ruamel-yaml version from https://archive.archlinux.org/packages/p/python-ruamel-yaml/python-ruamel-yaml-0.15.0-1-x86_64.pkg.tar.xz
I guess this can be written into the PKGBUILD (as an additional source) so that package is downloaded automatically along with its gpg sig and checked--but I am not sure this is proper form. Especially since Arch is now using version 0.15.33.
So I would say that it should be done manually--an active choice on the user to use an older python-ruamel-yaml version on his/her box (or not.)

nylocx commented on 2017-09-06 13:39

stef204 and aurelieng, thanks for your work. I would really like to update the package but it is still missing the "hack" in the PKGBUILD file to get around:

pkg_resources.ContextualVersionConflict: (ruamel.yaml 0.15.33 (/usr/lib/python3.6/site-packages), Requirement.parse('ruamel.yaml<=0.15'), {'borgmatic'})

If anyone has a patch to fix that I will add it to the PKGBUILD and update it in the AUR. I currently don't use borgmatic and have very limited time so I can't patch and test it my self.

stef204 commented on 2017-08-24 17:15

I modified the PKGBUILD for latest version.
Please see https://hub.darcs.net/stef204/pkgbuilds/browse/borgmatic/PKGBUILD

Some of the changes to PKGBUILD: drop python2 entirely in favor of just python (v3), upstream now includes systemd service and timer files; I kept intact the email ones, etc.
Also, the "hack": I checked with upstream and the correct python-ruamel-yaml version needed (at least for Arch users) is 0.15.0-1 which I manually installed on my box, getting it from https://archive.archlinux.org/packages/p/python-ruamel-yaml/python-ruamel-yaml-0.15.0-1-x86_64.pkg.tar.xz ; I had tried with latest version 0.15.32 AND with 0.15.18 but no joy. (If you do use the 0.15.0-1 version, remember to insert python-ruamel-yaml in the IgnorePkg section of /etc/pacman.conf. I had no packages depending on python-ruamel-yaml so it did not break any dependencies on my box. YMMV.)

It builds and seems to run OK. (Note: you will need to download the entire "borgmatic" directory [ https://hub.darcs.net/stef204/pkgbuilds/browse/borgmatic ] not just the PKGBUILD.)
Disclaimer: this is a work in progress--please feel free to critique and modify, etc. Possibly nylocx can fix/adopt and I have asked upstream re. python-ruamel-yaml version and when we can expect to use 0.15.32.
Edit: response from upstream
https://tree.taiga.io/project/witten-borgmatic/issue/37

aurelieng commented on 2017-08-23 08:55

I also noticed that borgmatic's `test_requirements.txt` now mentions `ruamel.yaml==0.15.18`. Maybe we can test if it works even though it still lags a bit behind Arch's 0.15.31? If so, we could either ask the borgmatic's maintainer to relax a bit the requirement constraints, or hack something right in the PKBUILD?

aurelieng commented on 2017-08-23 08:35

FYI, I just noticed pykalify in AUR: https://aur.archlinux.org/packages/python-pykwalify

nylocx commented on 2017-08-04 09:03

I currently have some problems updating this package as the package states to require pykwalify and ruaml.yaml <= 0.15. But arch ships with ruamel.yaml 0.15.23, so >= 0.15 and pykwakify is not in the repositories. If someone wants to step in here and add a python-pykwalifiy package or make sure that >=0.15 is ok, just email me.

nylocx commented on 2017-01-13 13:44

Ok, I found some time and added my systemd setup files with email notification (if sendmail is configured).
To configure where the mail is send you can edit the send-status-mail@.service file.

beardedlinuxgeek commented on 2017-01-13 12:01

+1 To adding systemd timers. Readers of this comment can find the files here:

https://raw.githubusercontent.com/witten/borgmatic/master/sample/systemd/borgmatic.service

https://raw.githubusercontent.com/witten/borgmatic/master/sample/systemd/borgmatic.timer

and the instructions:

sudo mv borgmatic.service borgmatic.timer /etc/systemd/system/
sudo systemctl enable borgmatic.timer
sudo systemctl start borgmatic.timer

BakaKuna commented on 2016-10-27 20:47

This is really helpfull. Thanks! I think it would be a nice addition to also install the unit and time for systemd found in the samples directory.