Package Details: borgmatic 1.3.13-1

Git Clone URL: https://aur.archlinux.org/borgmatic.git (read-only)
Package Base: borgmatic
Description: Simple, configuration-driven backup software for servers and workstations
Upstream URL: https://torsion.org/borgmatic/
Licenses: GPL3
Submitter: nylocx
Maintainer: devopsdeluxe (witten, nicoulaj)
Last Packager: nicoulaj
Votes: 25
Popularity: 0.417496
First Submitted: 2016-02-18 13:48
Last Updated: 2019-07-29 15:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

bjo commented on 2018-08-10 10:03

Any solution @nightglimmers issue?

delusional commented on 2018-07-28 11:49

From what I can tell, the newest borgmatic release no longer need the tox.ini hack in check().

The hack for setup.py and ruamel seems to soon be rendered superfluous too, so watch out for that.

Lastly, if you know the version required, please specify them in the PKGBUILD. There's no reason to allow people to install it with any ruamel version, when we know it will only work with versions between .15 and .16. The same is true for pykwalify, which has a min version of 1.6.0

devopsdeluxe commented on 2018-06-11 23:20

@karcher

What was the command you ran that generated that error?

karcher commented on 2018-06-11 14:42

I'm getting this error:

:: The following 11 package(s) are getting installed: aur/borgmatic / -> 1.1.15-2 community/python-atomicwrites / -> 1.1.5-4 community/python-dateutil / -> 2.7.3-1 community/python-flexmock / -> 0.10.2-2 community/python-more-itertools / -> 4.2.0-1 community/python-pluggy / -> 0.6.0-2 community/python-py / -> 1.5.3-1 aur/python-pykwalify / -> 1.6.0-3 community/python-pytest / -> 3.6.1-1 community/python-ruamel-yaml / -> 0.15.37-1 community/python-testfixtures / -> 6.1.0-1

?? Do you want to continue? Y/n: ~~ looking for new pkgbuilds and fetching them... resolving dependencies... looking for conflicting packages...

Packages (8) python-atomicwrites-1.1.5-4 python-dateutil-2.7.3-1 python-flexmock-0.10.2-2 python-more-itertools-4.2.0-1 python-pluggy-0.6.0-2 python-py-1.5.3-1 python-pytest-3.6.1-1 python-testfixtures-6.1.0-1

Total Download Size: 0.03 MiB Total Installed Size: 5.15 MiB

:: Proceed with installation? [Y/n] :: Retrieving packages... python-flexmock-0.10.2-2-any 27.6 KiB 0.00B/s 00:00 [####################################################################] 100% (8/8) checking keys in keyring [####################################################################] 100% (8/8) checking package integrity [####################################################################] 100% (8/8) loading package files [####################################################################] 100% (8/8) checking for file conflicts [####################################################################] 100% error: failed to commit transaction (conflicting files) python-dateutil: /usr/lib/python3.6/site-packages/dateutil/init.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/init.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/_common.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/_version.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/easter.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/relativedelta.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/rrule.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/tzwin.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/pycache/utils.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/_common.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/_version.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/easter.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/init.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/pycache/init.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/pycache/_parser.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/pycache/isoparser.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/_parser.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/parser/isoparser.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/relativedelta.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/rrule.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/init.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/pycache/init.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/pycache/_common.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/pycache/_factories.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/pycache/tz.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/pycache/win.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/_common.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/_factories.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/tz.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tz/win.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/tzwin.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/utils.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/zoneinfo/init.py exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/zoneinfo/pycache/init.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/zoneinfo/pycache/rebuild.cpython-36.pyc exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/zoneinfo/dateutil-zoneinfo.tar.gz exists in filesystem python-dateutil: /usr/lib/python3.6/site-packages/dateutil/zoneinfo/rebuild.py exists in filesystem Errors occurred, no packages were upgraded. 2018-06-11 16:38:10,668 - wrappers - pacman - ERROR - pacman query sudo pacman --ask=4 --sync --asdeps -- python-atomicwrites python-py python-more-itertools python-pluggy python-pytest python-flexmock python-testfixtures python-dateutil failed

nightglimmer commented on 2018-06-06 02:13

I am getting build errors in the check part. It is giving this error:

pykwalify.errors.RuleError: <ruleerror: '="" 4:="" code="" error="" found:="" key:="" path:="" unknown="" version=""></ruleerror:>

/usr/lib/python3.6/site-packages/pykwalify/rule.py:358: RuleError

thelinuxguy commented on 2018-02-06 12:12

Also testing the package like this doesn't do much.

You are testing using the dependencies listed in the source repository that are installed into a virtualenv. If you want the tests to reflect the users system, you should test it using the direct pytest command that is used in the tox.ini

This would mean that you need to add the test dependencies directly to make-depends. tox would then no longer be needed.

thelinuxguy commented on 2018-02-06 12:04

And now git is no longer needed. Also you shouldn't really need the provides. It's the same name anyway.

jakebailey commented on 2017-11-30 05:45

You added "make" itself to the makedepends, not "git".

devopsdeluxe commented on 2017-11-30 05:44

No problem!

I've implemented the changes you suggested.

jakebailey commented on 2017-11-30 01:39

Hate to be a stick in the mud, but you didn't up the pkgrel when you changed the commit.

Also, since you're using git to build the package, you should add it to the make dependencies since git isn't in base-devel (even though most AUR users will have it installed). Right now, this package fails to build in a fresh chroot/nspawn sandbox.