Package Details: breeze-plymouth 5.15.4-1

Git Clone URL: https://aur.archlinux.org/breeze-plymouth.git (read-only)
Package Base: breeze-plymouth
Description: Breeze theme for plymouth
Upstream URL: https://projects.kde.org/breeze-plymouth
Licenses: LGPL
Submitter: ImNtReal
Maintainer: ImNtReal
Last Packager: ImNtReal
Votes: 15
Popularity: 0.000001
First Submitted: 2016-03-27 23:07
Last Updated: 2019-04-02 14:55

Pinned Comments

ImNtReal commented on 2019-03-13 12:47

I've added the cpio hoook to the package. You may need to remove it from your filesystem if you added it manually.

ImNtReal commented on 2019-03-04 21:59

For users who have trouble validating the GPG keys used to sign the source package, this thread may be helpful: https://bbs.archlinux.org/viewtopic.php?id=191954

ctrlX commented on 2019-02-18 11:36

The breeze-plymouth theme utilizes the Plymouth label plugin (label.so) along with its dependencies (i.e. Pango). For some reason, this is not included into the initramfs image on Arch. Hence text labels and such is not displayed during boot.

To solve this, copy the following custom hook to /etc/initcpio/install/ : https://gitlab.com/pwyde/monochrome-plymouth/blob/master/hooks/breeze-plymouth

Then add the custom build hook breeze-plymouth to the HOOKS array in the /etc/mkinitcpio.conf configuration file.

HOOKS=(... breeze-plymouth)

Regenerate the initial ramdisk with mkinitcpio -p linux.

Latest Comments

« First ‹ Previous 1 2 3

faemir commented on 2017-05-12 15:34

Has there been any progress on fixing this?

Or is there a simple workaround for where to be putting the other files that aren't copied?

Aetf commented on 2016-11-04 23:20

I have the same problem with encrypted disk. After check the initramfs, I found that the images folder under /usr/share/plymouth/themes/breeze was not copied into the initramfs. I think that's why plymouth doesn't show anything when asking for password.

And the reason is that, the initcpio install hook only installs normal files (directories not included) from the theme folder to initramfs.

I've reported this to the plymouth and plymouth-git package on AUR.

plymouth: https://aur.archlinux.org/packages/plymouth/
plymouth-git: https://aur.archlinux.org/packages/plymouth-git/

Ravior commented on 2016-11-03 11:00

@somniumAeternam
I also have a problem with the Breeze plymouth when the disk is encrypted. More details can be found at:
https://bugs.kde.org/show_bug.cgi?id=367818
https://bugs.kde.org/show_bug.cgi?id=370981
https://bugs.kde.org/show_bug.cgi?id=371276

ImNtReal commented on 2016-10-26 19:01

I don't.

somniumAeternam commented on 2016-10-26 17:31

Other themes work for me, only breeze-plymouth is not working. Do you also have an encrypted drive which need to be decrypted at boot?

ImNtReal commented on 2016-10-26 15:24

It works for me on machines where Plymouth works. Have you followed the wiki entry? https://wiki.archlinux.org/index.php/plymouth

somniumAeternam commented on 2016-10-26 10:55

breeze-plymouth is not working for me. It shows a blank screen on startup. Does it work for any of you with and/or without password prompt? Are there certain kernel parameters needed? Many other graphical splash themes work for me.

ImNtReal commented on 2016-03-28 13:23

@Commander, I thought I'd fixed this. It's extra-cmake-modules. I'll push the update, again.

Commander commented on 2016-03-28 01:53

Im getting error,
CMake Error at CMakeLists.txt:7 (find_package):
Could not find a configuration file for package "ECM" that is compatible
with requested version "1.8.0".

The following configuration files were considered but not accepted:

/usr/share/ECM/cmake/ECMConfig.cmake, version: 1.5.0

-- Configuring incomplete, errors occurred!

Missing dep?