Package Details: brightd 0.4.1-1

Git Clone URL: https://aur.archlinux.org/brightd.git (read-only, click to copy)
Package Base: brightd
Description: Automatically dims screen when there is no user input (like a macbook :-).
Upstream URL: http://www.pberndt.com/Programme/Linux/brightd/
Keywords: brightness
Licenses: GPL2
Submitter: None
Maintainer: MarcinWieczorek
Last Packager: MarcinWieczorek
Votes: 17
Popularity: 0.147446
First Submitted: 2008-09-15 06:57 (UTC)
Last Updated: 2021-04-10 09:12 (UTC)

Latest Comments

1 2 Next › Last »

MarcinWieczorek commented on 2016-05-14 12:22 (UTC)

New version has its Makefile broken somehow, but I added a patch.

<deleted-account> commented on 2016-04-22 21:42 (UTC)

I disowned this package, since I'm not using brightd anymore. Feel free to adopt it.

analbeard commented on 2015-12-04 11:55 (UTC)

Still broken for me, however hashbang's md5sums do the trick.

<deleted-account> commented on 2015-07-02 12:45 (UTC)

Oh, I forgot to mention that my Yaourt is configured to fetch sources from AUR4 and I also tried to directly clone sources from git, but the result was the same.

<deleted-account> commented on 2015-07-02 12:41 (UTC)

==> Building and installing package ==> Making package: brightd 0.4.1-5 (Thu Jul 2 14:16:29 UTC 2015) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading brightd-0.4.1.tar.bz2... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 15972 100 15972 0 0 53201 0 --:--:-- --:--:-- --:--:-- 53240 -> Found brightd.service -> Found proposal.patch ==> ERROR: Integrity checks (md5) differ in size from the source array. ==> ERROR: Makepkg was unable to build brightd. ==> Restart building brightd ? [y/N] ==> -------------------------------- ==> And the following lines are the md5 sums. 42f1572c51162bf583d6436c3b36cc17 /tmp/yaourt-tmp-ldepandis/aur-brightd/brightd-0.4.1.tar.bz2 5fcf73f281941b09ea0942fd790bcc35 /tmp/yaourt-tmp-ldepandis/aur-brightd/brightd.install f5d5c7ed5c48d2dbe408986d5f6249fb /tmp/yaourt-tmp-ldepandis/aur-brightd/brightd.service 3a22db2941a790b7b9816de1cd217da8 /tmp/yaourt-tmp-ldepandis/aur-brightd/PKGBUILD 1fead7c648d3939970e7e62b21146734 /tmp/yaourt-tmp-ldepandis/aur-brightd/proposal.patch I tried to edit the md5sums() array to match those sums and brightd built smoothly. md5sums=('42f1572c51162bf583d6436c3b36cc17' 'f5d5c7ed5c48d2dbe408986d5f6249fb' '1fead7c648d3939970e7e62b21146734') Just for info: what files of the brightd sources have the sums 'a4717b49eb0494de57d19a3a574462ec' and '549926dcb3c43e0e6fe45025806d0782'?

csllbr commented on 2015-07-02 10:25 (UTC)

thanks for providing the correct patch - i've udpated it! I couldn't reproduce the integrity check problem: ==> Validating source files with md5sums... brightd-0.4.1.tar.bz2 ... Passed brightd.service ... Passed proposal.patch ... Passed If you want to look into that for yourself - I've granted you co-maintainer privileges!

<deleted-account> commented on 2015-07-02 10:09 (UTC)

csllbr, -4 revision fails at the integrity check due the following line: 'a4717b49eb0494de57d19a3a574462ec'. It also fails at patching (at the lines fixed by my patch) because the new proposal.patch is malformed, probably due a wrong cat. I fixed the patch and I uploaded it to my mega account, so you can download it. You can find it at: https://mega.co.nz/#!YgY1FQYC!EtLn050jBQ5qYortUmP-PEFbolZVb77eJAAKFPbnU70

<deleted-account> commented on 2015-06-30 21:49 (UTC)

Seems the issue is the 'inline' keyword used to declare both info() and isEventFileValid() functions. I've made a patch to fix this issue. http://pastebin.com/rhdPnHE0

whynothugo commented on 2015-05-18 07:28 (UTC)

Nope, same issue. Did you try building on a clean system, just to make sure?

csllbr commented on 2015-05-18 05:26 (UTC)

weird... I can't reproduce that. Building the latests 0.4.1-3 works without any errors. Does manually building the package work?