Package Details: brillo 1.4.10-1

Git Clone URL: https://aur.archlinux.org/brillo.git (read-only, click to copy)
Package Base: brillo
Description: Control the brightness of backlight and keyboard LED devices
Upstream URL: https://gitlab.com/cameronnemo/brillo
Licenses: GPL3
Submitter: CameronNemo
Maintainer: Aerz
Last Packager: Aerz
Votes: 14
Popularity: 0.079278
First Submitted: 2018-08-19 09:21 (UTC)
Last Updated: 2022-02-21 10:28 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

nicegamer7 commented on 2021-10-13 02:29 (UTC)

The issue is fixed with 1.4.10.

CameronNemo commented on 2021-08-20 21:06 (UTC)

@wh75er, I believe I have fixed the issue with 1.4.10. Please give it a try and update the AUR PKGBUILD if it works for you. I do not have access to an Arch install right now.

wh75er commented on 2021-08-20 20:42 (UTC)

In file included from src/exec.c:7:
src/exec.c: In function ‘exec_set’:
src/burno.h:19:9: error: ‘fd’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
   19 |         close(*fd);
      |         ^~~~~~~~~~
src/exec.c:107:17: note: ‘fd’ was declared here
  107 |         burn_fd fd;
      |                 ^~
cc1: all warnings being treated as errors
make: *** [<builtin>: src/exec.o] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
error making: brillo