Package Details: bro-git 2.5.r569.g057c982b9-1

Git Clone URL: https://aur.archlinux.org/bro-git.git (read-only)
Package Base: bro-git
Description: A powerful framework for network analysis and security monitoring. (IDS Intrusion Detection System)
Upstream URL: https://www.bro.org
Keywords: analysis bro detection ids intrusion monitoring network security system
Licenses: BSD
Submitter: mcd1992
Maintainer: mcd1992
Last Packager: mcd1992
Votes: 1
Popularity: 0.000141
First Submitted: 2016-12-08 16:08
Last Updated: 2018-05-14 20:21

Latest Comments

mcd1992 commented on 2018-05-14 23:33

Should be fixed now. Looks like they added more OpenSSL version checks which link against the wrong version of libcrypto.

Torxed commented on 2018-05-13 21:25

The fix discussed below doesn't work on x86_64. openssl-1.0 is installed.

Gives the following error:

CMake Error at cmake/OpenSSLTests.cmake:38 (message):
  OpenSSL 1.1 is not supported yet; please use OpenSSL 1.0
Call Stack (most recent call first):
  CMakeLists.txt:196 (include)

Libs installed:

[Torxed@archlinux ~]$ pacman -Q | grep openssl
lib32-openssl 1:1.1.0.h-1
openssl 1.1.0.h-1
openssl-1.0 1.0.2.o-1

Is it because you're looking for 1.0.0 but when in fact 1.0.2 is installed? Not entirely sure this is actually what's going on, but a quick glance that's why.

mcd1992 commented on 2017-05-03 04:20

Thanks for pointing this out. Fixed temporarily until openssl-1.1 support is added.

kotfic commented on 2017-05-02 16:15

Bro does not support openssl-1.1 (https://bro-tracker.atlassian.net/browse/BIT-1775)

installing openssl-1.0 and adding:

sed -i "/^append_cache_entry DISABLE_RUBY_BINDINGS BOOL true$/a\
append_cache_entry OPENSSL_CRYPTO_LIBRARY FILEPATH /usr/lib64/libcrypto.so.1.0.0\n\
append_cache_entry OPENSSL_INCLUDE_DIR PATH /usr/include/openssl-1.0\n\
append_cache_entry OPENSSL_SSL_LIBRARY FILEPATH /usr/lib64/libssl.so.1.0.0" configure

before the the call to configure fixed this issue for me.