Package Details: brother-brgenml1 3.1.0_1-3

Git Clone URL: https://aur.archlinux.org/brother-brgenml1.git (read-only)
Package Base: brother-brgenml1
Description: LPR and CUPS driver for various Brother DCP, HL and MFC models.
Upstream URL: http://support.brother.com/g/s/id/linux/en
Licenses: GPL version 2 for CUPS driver, custom:brother commercial license for LPR driver.
Submitter: swearchnick
Maintainer: swearchnick
Last Packager: swearchnick
Votes: 20
Popularity: 0.691667
First Submitted: 2014-07-13 19:22
Last Updated: 2017-12-09 10:13

Latest Comments

swearchnick commented on 2017-12-09 10:27

Latest list with compatible models from Brother: DCP-7055, DCP-7055W, DCP-7060D, DCP-7065DN, DCP-7070DW, DCP-8070D, DCP-8085DN, DCP-8110DN, DCP-8250DN, DCP-L2500D, DCP-L2520DW, DCP-L2540DN, DCP-L2560DW, HL-2130, HL-2132, HL-2135W, HL-2240, HL-2240D, HL-2250DN, HL-2270DW, HL-5340D, HL-5350DN, HL-5350DNLT, HL-5370DW, HL-5440D, HL-5450DN, HL-5450DNT, HL-5470DW, HL-6180DW, HL-6180DWT, HL-L2300D, HL-L2340DW, HL-L2360DN, HL-L2365DW, MFC-7360N, MFC-7460DN, MFC-7860DW, MFC-8370DN, MFC-8510DN, MFC-8520DN, MFC-8880DN, MFC-8890DW, MFC-8950DW, MFC-8950DWT, MFC-L2700DW, MFC-L2720DW, MFC-L2740DW

petrbel commented on 2017-11-25 09:45

@swearchnick oh, multilib was the problem. Thank you very much. The driver works great.

swearchnick commented on 2017-11-25 08:17

@petrbel: Cannot reproduce, do you have multilib repo enabled? Also try with no aur helper (plain makepkg).

petrbel commented on 2017-11-24 21:24

Hi, I'm having troubles with installation.

$ pacaur -S brother-brgenml1
:: Package brother-brgenml1 not found in repositories, trying AUR...
:: resolving dependencies...
:: no results found for lib32-glibc (dependency tree: brother-brgenml1 lib32-glibc)

Seems like lib32-glibc is no longer installable. Could you please help me installing the package? Thanks.

swearchnick commented on 2017-09-22 07:14

@timofonic: If you look on brothers site for drivers for your printer what drivers are listed? The reason for me to create this package was that the specific (non-generic) driver for my printer was buggy (problem with two-sided printing etc) and was replaced by brother with this more "generic" and has worked without issues since. So if brother lists this driver for your model then you should use "brother-brgenml1".

timofonic commented on 2017-09-22 02:00

What's better to install? Custom (brother-mfc-l2700dw) or generic (brother-brgenml1)? I'm confused

See this example...

Comparison to aid in creating a PKGBUILD for the Brother HLL6250DW printer driver
https://gist.github.com/miotatsu/6cf221bcdf047bf6b0c3a514b32ae6a6

fhdk commented on 2016-10-19 12:58

Thanks for maintaining this - a huge help :)

enno commented on 2016-07-28 07:47

Works with Brother MFC-7440N Printer

Thanks :)

sowieso commented on 2016-02-05 20:44

Worked with MFC-7360N only after I installed the package a2ps (driving me almost crazy). I suggest to add it to this package's dependencies.

garcs commented on 2016-01-03 19:56

Works for Brother DCP-1510.
Thanks.

All comments