Package Details: brother-dcp7065dn 3.1.0-3

Git Clone URL: https://aur.archlinux.org/brother-dcp7065dn.git (read-only)
Package Base: brother-dcp7065dn
Description: LPR and CUPS driver for the Brother DCP7065DN
Upstream URL: https://support.brother.com/g/b/downloadlist.aspx?c=de&lang=de&prod=dcp7065dn_all&os=128&flang=English
Licenses: custom:brother commercial license
Submitter: None
Maintainer: ghostbuster
Last Packager: ghostbuster
Votes: 12
Popularity: 0.000000
First Submitted: 2014-04-07 19:44
Last Updated: 2019-02-14 21:14

Latest Comments

« First ‹ Previous 1 2

Nowaker commented on 2014-05-12 20:09

@libernux I know multilib needs to be activated, but the driver should explicitly state it needs it. Otherwise people have to debug why the driver doesn't work just to find out multilib needs to be installed. This is what dependencies are for. ;) Official PKGBUILD guidelines even give an example. https://wiki.archlinux.org/index.php/PKGBUILD#arch

Anonymous comment on 2014-04-08 13:08

@nowaker, this is a bit of a problem, the brother drivers are 32-bit only.
On ARCH64 (wich burntsushi was using) you have to activate multilib.
See: https://wiki.archlinux.org/index.php/Multilib

Nowaker commented on 2014-04-08 10:50

@libernux, Great, keep up the good work. However, can you please consider burntsushi's comment? Maybe lib32-glibc should be in depends=() in every Brother drivers package.

Anonymous comment on 2014-04-07 19:44

Adopted and fixed PKGBUILD

burntsushi commented on 2012-06-30 19:08

It seems that this requires lib32-glibc. On a fresh system with no 32 bit libraries installed, I was getting this in /var/log/cups/error_log with the 'debug' logging level enabled:

D [30/Jun/2012:14:55:25 -0400] [Job 14] /usr/lib/cups/filter/brlpdwrapperDCP7065DN: line 139: /usr/local/Brother/Printer/DCP7065DN/cupswrapper/brcupsconfig4: No such file or directory

The error was seemingly mysterious, because CUPS itself otherwise reported "success". The printer just never responded.

Installing 'lib32-glibc' fixed this problem. All is well now.

Anonymous comment on 2011-10-16 02:40

I'm having some issues getting this to work. I start the CUPS daemon and add the printer, the driver is found, and the URI is "lpd://192.168.1.106/BINARY_P1". Now it just spits out blank pages until it's out of paper when I try to print anything. Both this and brother-dcp7065dn-cupswrapper are installed, along with a2ps, and avahi-daemon running. Also, this is on arch64.