Package Details: brother-hl1210w 3.0.1-2

Git Clone URL: https://aur.archlinux.org/brother-hl1210w.git (read-only)
Package Base: brother-hl1210w
Description: Brother HL-1210W CUPS driver. After installing this, install printer from CUPS web interface
Upstream URL: http://support.brother.com/g/b/downloadtop.aspx?c=au&lang=en&prod=hl1210w_eu_as
Licenses: GPL
Submitter: wmax641
Maintainer: l3mde
Last Packager: l3mde
Votes: 6
Popularity: 0.113519
First Submitted: 2016-01-03 02:20
Last Updated: 2018-07-29 17:10

Latest Comments

1 2 Next › Last »

wooptoo commented on 2018-10-17 08:58

Is lib32-glibc required if you only need the PPD file for cups? I'm on armv7 and can't install this package because there's no lib32*
Can the lib32-* be optional?

Cybersimio commented on 2018-01-06 07:28

i can't install this driver. i'm a new archlinux user (manjaro). please i need help

bakkegaard commented on 2017-12-05 15:48

It works fine on x86_64, you just need to put a quote (") at the end of line 5 in PKGBUILD.The maintainer should update this package accordingly.

Andy_Random commented on 2017-08-13 03:51

This package is a mess.
It will not build (typos, wrong dependency for i386)
Please delete it so someone else can take over.

participante commented on 2017-08-11 12:41

In the PKGBUILD, there is a missing " (quotation mark) at the end of pkgdesc.

:: Checking brother-hl1210w integrity...
/home/me/.cache/pacaur/brother-hl1210w/PKGBUILD: line 24: unexpected EOF while looking for matching `"'
/home/me/.cache/pacaur/brother-hl1210w/PKGBUILD: line 28: syntax error: unexpected end of file
==> ERROR: Failed to source /home/me/.cache/pacaur/brother-hl1210w/PKGBUILD

Also, the pkgrel should be 1.

:: Installing brother-hl1210w package(s)...
:: brother-hl1210w package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

wmax641 commented on 2017-07-24 13:49

This package was originally used to set up my own Brother HL-1210w printer. Looking up the Brother support website, the drivers offered for HL-1211w and HL-1212w both link to the same driver/wrapper files that this one uses. I can only infer from this, and from previous users below that this package may work for all 3 aforementioned printers.

wmax641 commented on 2017-07-24 13:48

@alkaline
you're right, ghostscript package should be a required dependency and I've updated the package to reflect this.

in psconvert2:
51 GHOST_SCRIPT=`which gs`

As for running it on a pi, I can't think of any straight forward way to make it work, you're gonna have to get creative. This package contains binaries compiled for 32bit x86. maybe submit a feature request to brother :p

alkaline commented on 2017-07-24 12:57

Is there a way to get this driver working for the ARM architecture (Raspberry Pi Model 3)?

alkaline commented on 2017-07-24 12:54

@vietphi
Because brother-hl1210w is a GDI printer, I think you also need to install the ghostscript package. I got a command not found in /opt/brother/Printers/HL1210W/lpd/psconvert2 error. The gs binary was missing.

@maintainer
Maybe you could add ghostscript to the list of required dependencies?

vietphi commented on 2017-04-09 06:20

Hi! Can you take a look? My printer is Brother HL1211w the driver package is this HL1210w but somehow I can't make it to works. It is just sent and the job completed but nothing printed.

In debian and Ubuntu I just install the deb package given in the Brother homepage and everything works.